summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorava1ar2015-06-17 00:37:05 -0400
committerava1ar2015-06-17 00:37:05 -0400
commite0ced34da88a0dcb96ab175b05cad1b6bf313b2d (patch)
tree3b4f05f165492f6d2c3257ffd1cc2459368ce5f7
downloadaur-e0ced34da88a0dcb96ab175b05cad1b6bf313b2d.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..952be5cc075b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = qmmp-plugin-pack
+ pkgdesc = Qmmp Plugin Pack
+ pkgver = 0.8.4
+ pkgrel = 1
+ url = http://qmmp.ylsoftware.com
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake>=2.8.0
+ depends = qmmp>=0.8.4
+ provides = qmmp-plugin-pack
+ source = http://qmmp.ylsoftware.com/files/plugins/qmmp-plugin-pack-0.8.4.tar.bz2
+ sha1sums = f05c3a99060fc6faf873ae68eaefd6cb648e70b3
+
+pkgname = qmmp-plugin-pack
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e8086dce37c6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: Andrew Panchenko <panchenkoac at gmail>
+# Maintainer: ava1ar <mail(at)ava1ar(dot)me>
+
+pkgname=qmmp-plugin-pack
+pkgver=0.8.4
+pkgrel=1
+pkgdesc="Qmmp Plugin Pack"
+arch=('i686' 'x86_64')
+url="http://qmmp.ylsoftware.com"
+license=('GPL')
+depends=("qmmp>=$pkgver")
+makedepends=('cmake>=2.8.0')
+provides=('qmmp-plugin-pack')
+source=(http://qmmp.ylsoftware.com/files/plugins/${pkgname}-${pkgver}.tar.bz2)
+sha1sums=('f05c3a99060fc6faf873ae68eaefd6cb648e70b3')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DLIB_DIR=/usr/lib -DCMAKE_BUILD_TYPE=RELEASE -DUSE_FFAP:BOOL=TRUE
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}