summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2021-07-18 20:09:21 +0200
committerFabioLolix2021-07-18 20:09:21 +0200
commitbb7874c005f71c4ba25aab88909026cef795bd44 (patch)
treebeb3c8c3d2f2cbd8d0090c451c2bb470c4b3d837
parentafcb9df2e505bd80db175d34138ec204cc39c7c2 (diff)
downloadaur-qmpdclient.tar.gz
v2.0.1
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD44
-rw-r--r--qmpdclient.changelog15
3 files changed, 33 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f6cfaaa7006..7d3d047af924 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = qmpdclient
- pkgdesc = A Qt4 client for MPD
- pkgver = 1.2.2
- pkgrel = 7
- url = https://bitcheese.net/wiki/QMPDClient
- changelog = qmpdclient.changelog
+ pkgdesc = Qt5 client for MPD
+ pkgver = 2.0.1
+ pkgrel = 1
+ url = https://github.com/ChaoticEnigma/qmpdclient
arch = x86_64
- license = GPL
+ license = GPL2
makedepends = cmake
- depends = qt4
- source = https://dump.bitcheese.net/files/qmpdclient-1.2.2.tar.bz2
- sha256sums = ed65705eaae8fb10fdce34ce20e010757a87423c2874479e1466e4368a866289
+ makedepends = qt5-tools
+ depends = qt5-base
+ depends = qt5-x11extras
+ depends = qt5-xmlpatterns
+ source = qmpdclient-2.0.1.tar.gz::https://github.com/ChaoticEnigma/qmpdclient/archive/refs/tags/v2.0.1.tar.gz
+ sha256sums = 3b09622dcf2c7b31c25ca9caf6db4a701ba79e7786d8b4d76908239df8655e15
pkgname = qmpdclient
-
diff --git a/PKGBUILD b/PKGBUILD
index 2cfdd3d39c32..b792612b440e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,32 @@
-# Maintainer: Jaroslav Lichtblau <svetlemodry@archlinux.org>
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Jaroslav Lichtblau <svetlemodry@archlinux.org>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Vinay S Shastry <vinayshastry@gmail.com>
pkgname=qmpdclient
-pkgver=1.2.2
-pkgrel=7
-pkgdesc="A Qt4 client for MPD"
-arch=('x86_64')
-url="https://bitcheese.net/wiki/QMPDClient"
-license=('GPL')
-depends=('qt4')
-makedepends=('cmake')
-changelog=$pkgname.changelog
-source=(https://dump.bitcheese.net/files/$pkgname-$pkgver.tar.bz2)
-sha256sums=('ed65705eaae8fb10fdce34ce20e010757a87423c2874479e1466e4368a866289')
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="Qt5 client for MPD"
+arch=(x86_64)
+url="https://github.com/ChaoticEnigma/qmpdclient"
+license=(GPL2)
+depends=(qt5-base qt5-x11extras qt5-xmlpatterns)
+makedepends=(cmake qt5-tools)
+source=("qmpdclient-${pkgver}.tar.gz::https://github.com/ChaoticEnigma/qmpdclient/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('3b09622dcf2c7b31c25ca9caf6db4a701ba79e7786d8b4d76908239df8655e15')
-build() {
- cd "${srcdir}"
- mkdir build
- cd build
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ mkdir -p build
+}
- cmake ../${pkgname} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr
- make
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}/build"
+ cmake ..
+ cmake --build .
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}" install
+ cd "${srcdir}/${pkgname}-${pkgver}/build"
+ cmake --install . --prefix ${pkgdir}/usr
}
diff --git a/qmpdclient.changelog b/qmpdclient.changelog
deleted file mode 100644
index f4f712c7c0c7..000000000000
--- a/qmpdclient.changelog
+++ /dev/null
@@ -1,15 +0,0 @@
-2011-10-22 Jaroslav Lichtblau <svetlemodry@archlinux.org>
- * qmpdclient 1.2.2-6 pacman hooks rebuild
-
-2011-11-12 Andrea Scarpino <andrea@archlinux.org>
- * qmpdclient 1.2.2-2
- * Qt 4.8 downgrade
-
-2011-10-22 Andrea Scarpino <andrea@archlinux.org>
- * qmpdclient 1.2.2-1
-
-2011-02-19 Jaroslav Lichtblau <svetlemodry@archlinux.org>
- * qmpdclient 1.2.1-1
-
-2011-02-01 Jaroslav Lichtblau <svetlemodry@archlinux.org>
- * qmpdclient 1.2-1