summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2019-05-01 11:44:41 +0000
committerAntonio Rojas2019-05-01 11:44:41 +0000
commitafcb9df2e505bd80db175d34138ec204cc39c7c2 (patch)
treea3de3511bf6d38e9179c249f6c1454fb4a4d469e
downloadaur-afcb9df2e505bd80db175d34138ec204cc39c7c2.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
-rw-r--r--qmpdclient.changelog15
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6f6cfaaa7006
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = qmpdclient
+ pkgdesc = A Qt4 client for MPD
+ pkgver = 1.2.2
+ pkgrel = 7
+ url = https://bitcheese.net/wiki/QMPDClient
+ changelog = qmpdclient.changelog
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ depends = qt4
+ source = https://dump.bitcheese.net/files/qmpdclient-1.2.2.tar.bz2
+ sha256sums = ed65705eaae8fb10fdce34ce20e010757a87423c2874479e1466e4368a866289
+
+pkgname = qmpdclient
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2cfdd3d39c32
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Jaroslav Lichtblau <svetlemodry@archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Vinay S Shastry <vinayshastry@gmail.com>
+
+pkgname=qmpdclient
+pkgver=1.2.2
+pkgrel=7
+pkgdesc="A Qt4 client for MPD"
+arch=('x86_64')
+url="https://bitcheese.net/wiki/QMPDClient"
+license=('GPL')
+depends=('qt4')
+makedepends=('cmake')
+changelog=$pkgname.changelog
+source=(https://dump.bitcheese.net/files/$pkgname-$pkgver.tar.bz2)
+sha256sums=('ed65705eaae8fb10fdce34ce20e010757a87423c2874479e1466e4368a866289')
+
+build() {
+ cd "${srcdir}"
+ mkdir build
+ cd build
+
+ cmake ../${pkgname} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/qmpdclient.changelog b/qmpdclient.changelog
new file mode 100644
index 000000000000..f4f712c7c0c7
--- /dev/null
+++ b/qmpdclient.changelog
@@ -0,0 +1,15 @@
+2011-10-22 Jaroslav Lichtblau <svetlemodry@archlinux.org>
+ * qmpdclient 1.2.2-6 pacman hooks rebuild
+
+2011-11-12 Andrea Scarpino <andrea@archlinux.org>
+ * qmpdclient 1.2.2-2
+ * Qt 4.8 downgrade
+
+2011-10-22 Andrea Scarpino <andrea@archlinux.org>
+ * qmpdclient 1.2.2-1
+
+2011-02-19 Jaroslav Lichtblau <svetlemodry@archlinux.org>
+ * qmpdclient 1.2.1-1
+
+2011-02-01 Jaroslav Lichtblau <svetlemodry@archlinux.org>
+ * qmpdclient 1.2-1