summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBłażej Szczygieł2016-06-27 21:50:40 +0200
committerBłażej Szczygieł2016-06-27 21:51:07 +0200
commit13b2cd214a3a112d96503f7b525b2e2cd5e74a67 (patch)
tree338e7c497a4f6369b8edce99224bd209c53c6019
parent0f9bf0c34ab4c30e216e79ff35e6df5ab97e2b84 (diff)
downloadaur-13b2cd214a3a112d96503f7b525b2e2cd5e74a67.tar.gz
Easily allow to link to jemalloc
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8d537cc572d..93e943f5b9f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Jun 26 21:00:00 UTC 2016
+# Mon Jun 27 19:50:06 UTC 2016
pkgbase = qmplay2-git
pkgdesc = QMPlay2 is a video and audio player which can play most formats and codecs
pkgver = 16.06.26
diff --git a/PKGBUILD b/PKGBUILD
index bc8e7a685f5c..3d0f30de908b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,13 +25,17 @@ pkgver()
build()
{
- #Uncomment below line if you don't want to have 'libsidplayfp' dependency and remove it from 'depends' list
- #USE_SIDPLAYFP='-DUSE_CHIPTUNE_SID=No'
+ # Uncomment below line if you don't want to have 'libsidplayfp' dependency and remove it from 'depends' list
+ #USE_SIDPLAYFP='-DUSE_CHIPTUNE_SID=OFF'
+
+ # Uncomment below two lines if you want to use 'jemalloc' and add it to 'depends' list
+ #unset LDFLAGS
+ #USE_JEMALLOC='-DUSE_JEMALLOC=ON'
cd $srcdir
mkdir -p QMPlay2-build
cd QMPlay2-build
- cmake ../QMPlay2 -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib -DUSE_QT5=YES $USE_SIDPLAYFP
+ cmake ../QMPlay2 -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib -DUSE_QT5=YES $USE_JEMALLOC $USE_SIDPLAYFP
time make
}