summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBłażej Szczygieł2020-05-02 17:23:32 +0200
committerBłażej Szczygieł2020-05-02 17:23:32 +0200
commit62b3d4ea25060e3419d8a78662f847f956790c03 (patch)
tree753cbb3780833e5d08e428d33f0c57b3655cbcab
parentc9e39509aff9900f18a773b9775b5d8ecdbbd7f0 (diff)
downloadaur-62b3d4ea25060e3419d8a78662f847f956790c03.tar.gz
Update version, fix submodules
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD27
2 files changed, 26 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0bef19d57a7b..e2c00b206dce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qmplay2-git
pkgdesc = QMPlay2 is a video and audio player which can play most formats and codecs
- pkgver = 19.12.19
- pkgrel = 4
+ pkgver = 20.05.02.r0.g0b73f2ee
+ pkgrel = 1
url = https://github.com/zaps166/QMPlay2
arch = i686
arch = x86_64
@@ -37,7 +37,11 @@ pkgbase = qmplay2-git
optdepends = game_music_emu-kode54-git: Better chiptune support (less bugs in sound, AUR package)
provides = qmplay2
conflicts = qmplay2
- source = git+https://github.com/zaps166/QMPlay2
+ source = git+https://github.com/zaps166/QMPlay2.git
+ source = git+https://github.com/zaps166/QmVk.git
+ source = git+https://github.com/KhronosGroup/Vulkan-Headers.git
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = qmplay2-git
diff --git a/PKGBUILD b/PKGBUILD
index 613daec4c578..9276f9ac174e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: zaps166 <spaz16@wp.pl>
pkgname=qmplay2-git
-pkgver=19.12.19
-pkgrel=4
+pkgver=20.05.02.r0.g0b73f2ee
+pkgrel=1
pkgdesc='QMPlay2 is a video and audio player which can play most formats and codecs'
arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
url='https://github.com/zaps166/QMPlay2'
@@ -13,8 +13,16 @@ optdepends=('pulseaudio: PulseAudio support'
conflicts=('qmplay2')
provides=('qmplay2')
makedepends=('ninja' 'clang' 'git' 'pkg-config' 'qt5-tools' 'cmake' 'fakeroot' 'shaderc')
-source=('git+https://github.com/zaps166/QMPlay2')
-sha256sums=('SKIP')
+source=(
+ 'git+https://github.com/zaps166/QMPlay2.git'
+ 'git+https://github.com/zaps166/QmVk.git'
+ 'git+https://github.com/KhronosGroup/Vulkan-Headers.git'
+)
+sha256sums=(
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+)
pkgver() {
cd QMPlay2
@@ -22,13 +30,15 @@ pkgver() {
}
prepare() {
+ mkdir -p QMPlay2-build
cd QMPlay2
- git submodule update --init
+ git submodule init
+ git config submodule.src/qmvk.url ../QmVk
+ git config submodule.src/qmplay2/vulkan/headers.url ../Vulkan-Headers
+ git submodule update
}
build() {
- cd $srcdir
- mkdir -p QMPlay2-build
cd QMPlay2-build
cmake \
-G Ninja \
@@ -39,7 +49,8 @@ build() {
-DCMAKE_INSTALL_LIBDIR=lib \
-DUSE_LINK_TIME_OPTIMIZATION=OFF \
-DUSE_PCH=ON \
- -DUSE_GLSLC=ON
+ -DUSE_GLSLC=ON \
+ -DUSE_GIT_VERSION=ON
time ninja
}