summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBłażej Szczygieł2016-06-18 18:54:43 +0200
committerBłażej Szczygieł2016-06-18 18:54:43 +0200
commit7c4f63b8c67f82ce3b92bb7958199c9f24a8c943 (patch)
treebf3e0fb681030c5b88b90e19c5b85af9665e9837
parent76a16ae8e312d21338e841566d039b2afce816fb (diff)
downloadaur-7c4f63b8c67f82ce3b92bb7958199c9f24a8c943.tar.gz
Fix build w/o qt5-x11extras (temporary solution)
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rw-r--r--no-cmake-x11extras.patch26
3 files changed, 34 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a8cbf8ec96f9..ed1b5e6cf28a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sat Jun 18 11:05:48 UTC 2016
+# Sat Jun 18 16:54:09 UTC 2016
pkgbase = qmplay2-git
pkgdesc = QMPlay2 is a video and audio player which can play most formats and codecs
pkgver = 16.06.14
@@ -38,7 +38,9 @@ pkgbase = qmplay2-git
provides = qmplay2
conflicts = qmplay2
source = git+https://github.com/zaps166/QMPlay2
+ source = no-cmake-x11extras.patch
sha256sums = SKIP
+ sha256sums = 3ea8d7bb627f0fec5d91d573be7d44430f0053e869442ba4b58b1e54b494cfd6
pkgname = qmplay2-git
diff --git a/PKGBUILD b/PKGBUILD
index c0d75f63cc30..46629f458c2c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,8 +14,8 @@ optdepends=('pulseaudio: PulseAudio support'
conflicts=('qmplay2')
provides=('qmplay2')
makedepends=('make' 'gcc' 'git' 'pkg-config' 'qt5-tools' 'cmake')
-source=('git+https://github.com/zaps166/QMPlay2')
-sha256sums=('SKIP')
+source=('git+https://github.com/zaps166/QMPlay2' 'no-cmake-x11extras.patch')
+sha256sums=('SKIP' '3ea8d7bb627f0fec5d91d573be7d44430f0053e869442ba4b58b1e54b494cfd6')
install=$pkgname.install
pkgver()
@@ -29,6 +29,9 @@ build()
#Uncomment below line if you don't want to have 'libsidplayfp' dependency and remove it from 'depends' list
#USE_SIDPLAYFP='-DUSE_CHIPTUNE_SID=No'
+ cd $srcdir/QMPlay2
+ patch -p1 < ../no-cmake-x11extras.patch
+
cd $srcdir
mkdir -p QMPlay2-build
cd QMPlay2-build
diff --git a/no-cmake-x11extras.patch b/no-cmake-x11extras.patch
new file mode 100644
index 000000000000..e3d35e40c4fd
--- /dev/null
+++ b/no-cmake-x11extras.patch
@@ -0,0 +1,26 @@
+diff --git a/src/gui/CMakeLists.txt b/src/gui/CMakeLists.txt
+index a4451a7..874489d 100644
+--- a/src/gui/CMakeLists.txt
++++ b/src/gui/CMakeLists.txt
+@@ -97,7 +97,7 @@ add_executable(QMPlay2
+ )
+
+ if(USE_QT5)
+- qt5_use_modules(QMPlay2 Gui Widgets Network X11Extras)
++ qt5_use_modules(QMPlay2 Gui Widgets Network)
+ else()
+ target_link_libraries(QMPlay2 Qt4::QtGui Qt4::QtCore Qt4::QtNetwork)
+ endif()
+diff --git a/src/modules/XVideo/CMakeLists.txt b/src/modules/XVideo/CMakeLists.txt
+index b01e454..02c8747 100644
+--- a/src/modules/XVideo/CMakeLists.txt
++++ b/src/modules/XVideo/CMakeLists.txt
+@@ -36,7 +36,7 @@ add_library(${PROJECT_NAME} MODULE
+ )
+
+ if(USE_QT5)
+- qt5_use_modules(${PROJECT_NAME} Gui Widgets X11Extras)
++ qt5_use_modules(${PROJECT_NAME} Gui Widgets)
+ else()
+ target_link_libraries(${PROJECT_NAME} Qt4::QtGui Qt4::QtCore)
+ endif()