summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBłażej Szczygieł2020-03-10 19:59:30 +0100
committerBłażej Szczygieł2020-03-10 19:59:30 +0100
commit9752fb87c99555ce0c759b384aa586a362132181 (patch)
tree9786438884049c29acda06c8bb7ecc407e245294
parent6ce6415ffd4f8498198ff06a8330d5ab6ea4d9cb (diff)
downloadaur-9752fb87c99555ce0c759b384aa586a362132181.tar.gz
pkgver and indentation changes
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD32
2 files changed, 16 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2a4d1f22038..4edacb1a51ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qmplay2-git
pkgdesc = QMPlay2 is a video and audio player which can play most formats and codecs
pkgver = 19.12.19
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/zaps166/QMPlay2
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index e55d0c3d8d2c..52b3c296aba9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=qmplay2-git
pkgver=19.12.19
-pkgrel=2
+pkgrel=3
pkgdesc='QMPlay2 is a video and audio player which can play most formats and codecs'
arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
url='https://github.com/zaps166/QMPlay2'
@@ -16,25 +16,23 @@ makedepends=('make' 'gcc' 'git' 'pkg-config' 'qt5-tools' 'cmake' 'fakeroot')
source=('git+https://github.com/zaps166/QMPlay2')
sha256sums=('SKIP')
-pkgver()
-{
- $srcdir/QMPlay2/version
+pkgver() {
+ cd QMPlay2
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-build()
-{
- # Uncomment below line if you don't want to have 'libsidplayfp' dependency and remove it from 'depends' list
- #USE_SIDPLAYFP='-DUSE_CHIPTUNE_SID=OFF'
+build() {
+ # Uncomment below line if you don't want to have 'libsidplayfp' dependency and remove it from 'depends' list
+ #USE_SIDPLAYFP='-DUSE_CHIPTUNE_SID=OFF'
- cd $srcdir
- mkdir -p QMPlay2-build
- cd QMPlay2-build
- cmake ../QMPlay2 -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib -DUSE_LINK_TIME_OPTIMIZATION=OFF -DUSE_PCH=ON $USE_SIDPLAYFP
- time make
+ cd $srcdir
+ mkdir -p QMPlay2-build
+ cd QMPlay2-build
+ cmake ../QMPlay2 -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib -DUSE_LINK_TIME_OPTIMIZATION=OFF -DUSE_PCH=ON $USE_SIDPLAYFP
+ time make
}
-package()
-{
- cd $srcdir/QMPlay2-build
- make DESTDIR=$pkgdir install
+package() {
+ cd $srcdir/QMPlay2-build
+ make DESTDIR=$pkgdir install
}