summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBłażej Szczygieł2016-06-17 15:34:50 +0200
committerBłażej Szczygieł2016-06-17 15:35:02 +0200
commitcfcbcd20e8d3885423789496a264d7b6d5724a70 (patch)
tree34cbaf9c821e15acc19624ff1cef1bc4d6acf0c1
parent91e896e91d7853933c336a96e10f67848810dfb6 (diff)
downloadaur-cfcbcd20e8d3885423789496a264d7b6d5724a70.tar.gz
Easily disable SID dependency
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD7
3 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 576098dfb127..d4cf59107e1a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Wed Jun 15 21:18:19 UTC 2016
+# Fri Jun 17 13:34:00 UTC 2016
pkgbase = qmplay2-git
pkgdesc = QMPlay2 is a video and audio player which can play most formats and codecs
pkgver = 16.06.14
@@ -20,6 +20,7 @@ pkgbase = qmplay2-git
makedepends = cmake
depends = qt5-base
depends = qt5-x11extras
+ depends = xdg-utils
depends = ffmpeg
depends = libass
depends = libgl
@@ -32,7 +33,6 @@ pkgbase = qmplay2-git
depends = libpulse
depends = libgme
depends = libsidplayfp
- depends = xdg-utils
optdepends = pulseaudio
optdepends = youtube-dl
provides = qmplay2
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..30ba08cfd0b1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar*
+QMPlay2/
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
index 8b26f6972312..dad1a1f4f11e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgdesc='QMPlay2 is a video and audio player which can play most formats and cod
arch=('i686' 'x86_64' 'armv7' 'armv6' 'armv5')
url='http://qt-apps.org/content/show.php/QMPlay2?content=153339'
license=('LGPL')
-depends=('qt5-base' 'qt5-x11extras' 'ffmpeg' 'libass' 'libgl' 'libva' 'libxv' 'alsa-lib' 'libcdio' 'taglib' 'libcddb' 'libpulse' 'libgme' 'libsidplayfp' 'xdg-utils')
+depends=('qt5-base' 'qt5-x11extras' 'xdg-utils' 'ffmpeg' 'libass' 'libgl' 'libva' 'libxv' 'alsa-lib' 'libcdio' 'taglib' 'libcddb' 'libpulse' 'libgme' 'libsidplayfp')
optdepends=('pulseaudio' 'youtube-dl')
conflicts=('qmplay2')
provides=('qmplay2')
@@ -24,10 +24,13 @@ pkgver()
build()
{
+ #Uncomment below line if you don't want to have 'libsidplayfp' dependency and remove it from 'depends' list
+ #USE_SIDPLAYFP='-DUSE_CHIPTUNE_SID=No'
+
cd $srcdir
mkdir -p QMPlay2-build
cd QMPlay2-build
- time cmake ../QMPlay2 -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib
+ cmake ../QMPlay2 -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib $USE_SIDPLAYFP
time make
}