summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Schmidtke2018-07-16 12:29:35 -0400
committerJakub Schmidtke2018-07-16 12:29:35 -0400
commitd247ae457b4655afea1b2b993b6eee29cc2aeb66 (patch)
tree7b25946acc2ab67d3a6a8eb13be2695ac159753c
parent2d7f544b1ead997e34eff2f2c8dca4dfd069152b (diff)
downloadaur-d247ae457b4655afea1b2b993b6eee29cc2aeb66.tar.gz
Fixed a build issue
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 479d16f86cac..6e758e6198fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=qnapi
pkgver=0.2.3
-pkgrel=2
+pkgrel=3
pkgdesc="Qt5 client for downloading movie subtitles from NapiProjekt, OpenSubtitles, Napisy24"
arch=('i686' 'x86_64' 'armv7h')
url="https://github.com/QNapi/${pkgname}"
@@ -14,6 +14,11 @@ changelog=ChangeLog
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/QNapi/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
sha256sums=('8debb6862e96e52e4060131b314d9b887051a646a4a57c87c0287f2655357046')
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ sed -i '/^#include "subdatawidget.h"$/a #include <QIcon>' gui/src/forms/subdatawidget.cpp
+}
+
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
qmake-qt5 QMAKE_DEFAULT_INCDIRS="" ${pkgname}.pro