summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaxonbeta2019-09-05 15:24:55 -0500
committerSaxonbeta2019-09-05 15:24:55 -0500
commit6d9669c3e132900e7d4223414de5e6620f7429c3 (patch)
tree71e8a671d019696f68d34f4f1dcaf5070266b72d
parentb663fd63266d4d761d5e34a9785a3fc47389794c (diff)
downloadaur-6d9669c3e132900e7d4223414de5e6620f7429c3.tar.gz
Update to v2.0, compatible with Zotero 5
-rw-r--r--.SRCINFO14
-rwxr-xr-xPKGBUILD19
-rwxr-xr-xqnotero.install11
3 files changed, 15 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 25f1bd8413f6..c7040c9dd842 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,18 @@
pkgbase = qnotero
pkgdesc = A Qt application which provides access to your Zotero references
- pkgver = 1.0.0
- pkgrel = 2
- url = http://cogsci.nl/software/qnotero
- install = qnotero.install
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/saxonbeta/qnotero
arch = any
license = GPL
- depends = python-pyqt4
+ depends = python-qtpy
depends = pdftk-bin
- depends = desktop-file-utils
optdepends = gnote: for integration with gnote
optdepends = python-levenshtein: for integration with gnote
provides = gnotero
replaces = gnotero
- source = https://github.com/smathot/qnotero/archive/release/1.0.0.tar.gz
- sha256sums = e577a8fa3d77006f6f6e5851510ba0e2aa2ebec0895cd80813cbefa98aa3ef67
+ source = https://github.com/saxonbeta/qnotero/archive/2.0.0.tar.gz
+ sha256sums = 823bcec8f6c63c5a36c8c4e621e2dcc41961c8922c638dfea0bb6acb49cff197
pkgname = qnotero
diff --git a/PKGBUILD b/PKGBUILD
index 30952387776a..652265ebaa3e 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,28 @@
# Maintainer: saxonbeta <saxonbeta at gmail _ com>
+#Contributor: Thomas Jost <schnouki at schnouki _ net>
pkgname=qnotero
-pkgver=1.0.0
-pkgrel=2
+pkgver=2.0.0
+pkgrel=1
pkgdesc="A Qt application which provides access to your Zotero references"
arch=(any)
-url="http://cogsci.nl/software/qnotero"
+url="https://github.com/saxonbeta/qnotero"
license=('GPL')
-depends=('python-pyqt4' 'pdftk-bin' 'desktop-file-utils')
+depends=('python-qtpy' 'pdftk-bin')
optdepends=(
'gnote: for integration with gnote'
'python-levenshtein: for integration with gnote'
)
provides=("gnotero")
replaces=("gnotero")
-source=(https://github.com/smathot/${pkgname}/archive/release/${pkgver}.tar.gz)
-sha256sums=('e577a8fa3d77006f6f6e5851510ba0e2aa2ebec0895cd80813cbefa98aa3ef67')
-install=qnotero.install
+source=(https://github.com/saxonbeta/qnotero/archive/${pkgver}.tar.gz)
+sha256sums=('823bcec8f6c63c5a36c8c4e621e2dcc41961c8922c638dfea0bb6acb49cff197')
build() {
- cd "$srcdir/$pkgname-release-$pkgver"
+ cd "$srcdir/$pkgname-$pkgver"
python setup.py build
}
package() {
- cd "$srcdir/$pkgname-release-$pkgver"
+ cd "$srcdir/$pkgname-$pkgver"
python setup.py install --root=$pkgdir
-
}
diff --git a/qnotero.install b/qnotero.install
deleted file mode 100755
index 2eaa60550d51..000000000000
--- a/qnotero.install
+++ /dev/null
@@ -1,11 +0,0 @@
-post_install() {
- update-desktop-database -q
-}
-
-post_upgrade() {
- post_install $1
-}
-
-post_remove() {
- post_install $1
-}