summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsaxonbeta2015-06-09 07:23:08 -0500
committersaxonbeta2015-06-09 07:23:08 -0500
commitb663fd63266d4d761d5e34a9785a3fc47389794c (patch)
treebc9eaa6ef2e0dbe13fc7049aa8311121db518239
downloadaur-b663fd63266d4d761d5e34a9785a3fc47389794c.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rwxr-xr-xPKGBUILD29
-rwxr-xr-xqnotero.install11
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..25f1bd8413f6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = qnotero
+ pkgdesc = A Qt application which provides access to your Zotero references
+ pkgver = 1.0.0
+ pkgrel = 2
+ url = http://cogsci.nl/software/qnotero
+ install = qnotero.install
+ arch = any
+ license = GPL
+ depends = python-pyqt4
+ depends = pdftk-bin
+ depends = desktop-file-utils
+ optdepends = gnote: for integration with gnote
+ optdepends = python-levenshtein: for integration with gnote
+ provides = gnotero
+ replaces = gnotero
+ source = https://github.com/smathot/qnotero/archive/release/1.0.0.tar.gz
+ sha256sums = e577a8fa3d77006f6f6e5851510ba0e2aa2ebec0895cd80813cbefa98aa3ef67
+
+pkgname = qnotero
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..30952387776a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: saxonbeta <saxonbeta at gmail _ com>
+pkgname=qnotero
+pkgver=1.0.0
+pkgrel=2
+pkgdesc="A Qt application which provides access to your Zotero references"
+arch=(any)
+url="http://cogsci.nl/software/qnotero"
+license=('GPL')
+depends=('python-pyqt4' 'pdftk-bin' 'desktop-file-utils')
+optdepends=(
+ 'gnote: for integration with gnote'
+ 'python-levenshtein: for integration with gnote'
+)
+provides=("gnotero")
+replaces=("gnotero")
+source=(https://github.com/smathot/${pkgname}/archive/release/${pkgver}.tar.gz)
+sha256sums=('e577a8fa3d77006f6f6e5851510ba0e2aa2ebec0895cd80813cbefa98aa3ef67')
+install=qnotero.install
+
+build() {
+ cd "$srcdir/$pkgname-release-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-release-$pkgver"
+ python setup.py install --root=$pkgdir
+
+}
diff --git a/qnotero.install b/qnotero.install
new file mode 100755
index 000000000000..2eaa60550d51
--- /dev/null
+++ b/qnotero.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}