summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Bantyev2017-02-25 22:56:23 +0300
committerAlexander Bantyev2017-02-25 22:56:23 +0300
commit9178782658752dc26894049d9017ec81beacd93d (patch)
tree1142563085501d4fb6858b820033933257f1a972
parent27e4b0097b86bbdba3536043e926aa007d48664b (diff)
downloadaur-9178782658752dc26894049d9017ec81beacd93d.tar.gz
Updated PKGBUILD from official github repo
-rw-r--r--PKGBUILD78
1 files changed, 60 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bf214f1bef57..ff52b1fdc881 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,62 @@
-# Maintainer: Александр Бантьев (Alexander Bantyev) aka balsoft <balsoft@yandex.ru>
-# Contributor: wadealer
-pkgname="qomp"
-pkgver="1.1.1"
+# Maintainer: alex korobtsov <korobcoff@gmail.com>
+# Maintainer: Alexander Bantyev <balsoft@yandex.ru>
+pkgname=qomp-qt5-git
+pkgver=0.7.5
pkgrel=1
-pkgdesc="Quick(Qt) Online Music Player - one player for different online music hostings."
-arch=("any")
-url="https://sourceforge.net/projects/qomp/"
-license=("GPLv2")
-source=("https://downloads.sourceforge.net/project/qomp/1.1.1/qomp_1.1.1_src.tar.gz?r=https%3A%2F%2Fsourceforge.net%2Fprojects%2Fqomp%2Ffiles%2F1.1.1%2F&ts=1486883225&use_mirror=netix")
-md5sums=("639b292fe2ac8e955a6c491c36cfefac")
-function build {
- cd "$srcdir/$pkgname-$pkgver"
- cmake .
- sudo make install prefix="$pkgdir"
-
+pkgdesc="Quick(Qt) Online Music Player"
+arch=('i686' 'x86_64')
+url="http://qomp.sourceforge.net/"
+license=('GPL2')
+depends=( 'taglib' 'qt5-base' 'qt5-tools' 'qt5-multimedia'
+'qt5-xmlpatterns' 'gstreamer0.10-bad-plugins'
+'gstreamer0.10-base-plugins' 'gstreamer0.10-ffmpeg'
+'gstreamer0.10-good-plugins' 'gstreamer0.10-ugly-plugins' )
+makedepends=('git')
+conflicts=(qomp)
+source=(git+https://github.com/qomp/qomp)
+md5sums=('SKIP')
+
+pkgver() {
+ cd qomp
+ git describe --tags | cut -d - -f 1-2 --output-delimiter=.
}
-function package {
- echo "ok"
-} \ No newline at end of file
+
+_gitroot=https://github.com/qomp/
+_gitname=qomp
+_plugins="filesystemplugin;urlplugin;prostopleerplugin;myzukaruplugin;yandexmusicplugin;lastfmplugin;tunetofileplugin;mprisplugin;notificationsplugin"
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [[ -d "$_gitname" ]]; then
+ cd "$_gitname" && git pull origin
+ msg "The local files are updated."
+ else
+ git clone "$_gitroot" "$_gitname"
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting build..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitname-build/"
+ git submodule init
+ git submodule update
+
+ # BUILD HERE
+
+cmake -DCMAKE_INSTALL_PREFIX=/usr/ \
+ -DUSE_QT5=ON \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DBUILD_PLUGINS=${_plugins}
+
+make
+}
+
+package() {
+ cd "$srcdir/$_gitname-build/"
+ make DESTDIR="$pkgdir/" install
+
+}
+