summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2017-09-20 00:54:09 +0200
committerFabioLolix2017-09-20 00:54:09 +0200
commitc3a438e1ca424ebbf680c7fb4de197b1f2631977 (patch)
tree3ed00fa1ad18e69d6279f4bfe44ab4f8907edeeb
parent273302e7c9db063c2da713c2ff4c685d46528bec (diff)
downloadaur-c3a438e1ca424ebbf680c7fb4de197b1f2631977.tar.gz
Updated to version 1.2.1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD63
2 files changed, 30 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5358a46e4d1f..9976d224ce08 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qomp
pkgdesc = Quick(Qt) Online Music Player
- pkgver = 0.7.5
+ pkgver = 1.2.1
pkgrel = 1
url = http://qomp.sourceforge.net/
arch = i686
@@ -9,18 +9,18 @@ pkgbase = qomp
makedepends = git
makedepends = make
makedepends = cmake
- makedepends = libcue
depends = taglib
depends = qt5-base
depends = qt5-tools
+ depends = qt5-x11extras
depends = qt5-multimedia
depends = qt5-xmlpatterns
- depends = gstreamer0.10-bad-plugins
- depends = gstreamer0.10-base-plugins
- depends = gstreamer0.10-ffmpeg
- depends = gstreamer0.10-good-plugins
- depends = gstreamer0.10-ugly-plugins
- source = git+https://github.com/qomp/qomp
+ depends = gstreamer
+ depends = libcue
+ depends = gst-plugins-good
+ optdepends = gst-plugins-bad
+ optdepends = gst-plugins-ugly
+ source = git+https://github.com/qomp/qomp#commit=0ba092306affeb2c68b1a00dedbf5fa8f749ad45
md5sums = SKIP
pkgname = qomp
diff --git a/PKGBUILD b/PKGBUILD
index afa96b9bc2aa..ecc35dc2e38f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,61 +1,42 @@
-# Maintainer: alex korobtsov <korobcoff@gmail.com>
-# Maintainer: Alexander Bantyev <balsoft@yandex.ru>
+# Maintainer: Fabio Loli <loli_fabio@protonmail.com>
+# Contributor: alex korobtsov <korobcoff@gmail.com>
+# Contributor: Alexander Bantyev <balsoft@yandex.ru>
+
pkgname=qomp
-pkgver=0.7.5
+pkgver=1.2.1
pkgrel=1
pkgdesc="Quick(Qt) Online Music Player"
arch=('i686' 'x86_64')
url="http://qomp.sourceforge.net/"
license=('GPL2')
-depends=( 'taglib' 'qt5-base' 'qt5-tools' 'qt5-multimedia'
-'qt5-xmlpatterns' 'gstreamer0.10-bad-plugins'
-'gstreamer0.10-base-plugins' 'gstreamer0.10-ffmpeg'
-'gstreamer0.10-good-plugins' 'gstreamer0.10-ugly-plugins' )
-makedepends=('git' 'make' 'cmake' 'libcue')
-source=(git+https://github.com/qomp/qomp)
-md5sums=('SKIP')
+depends=('taglib' 'qt5-base' 'qt5-tools' 'qt5-x11extras'
+ 'qt5-multimedia' 'qt5-xmlpatterns'
+ 'gstreamer' 'libcue' 'gst-plugins-good')
+optdepends=('gst-plugins-bad'
+ 'gst-plugins-ugly')
+makedepends=('git' 'make' 'cmake')
+_commit=0ba092306affeb2c68b1a00dedbf5fa8f749ad45 #tag 1.2.1
+source=("git+https://github.com/qomp/qomp#commit=$_commit")
+md5sums=('SKIP')
pkgver() {
- cd qomp
- git describe --tags | cut -d - -f 1-2 --output-delimiter=.
+ cd $pkgname
+ git describe --tags | sed 's/^v//;s/-/+/g'
}
-_gitroot=https://github.com/qomp/
-_gitname=qomp
-_plugins="filesystemplugin;urlplugin;prostopleerplugin;myzukaruplugin;yandexmusicplugin;lastfmplugin;tunetofileplugin;mprisplugin;notificationsplugin"
build() {
- cd "$srcdir"
- msg "Connecting to GIT server...."
-
- if [[ -d "$_gitname" ]]; then
- cd "$_gitname" && git pull origin
- msg "The local files are updated."
- else
- git clone "$_gitroot" "$_gitname"
- fi
-
- msg "GIT checkout done or server timeout"
- msg "Starting build..."
-
- rm -rf "$srcdir/$_gitname-build"
- git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
- cd "$srcdir/$_gitname-build/"
+ cd "$srcdir/${pkgname}"
git submodule init
git submodule update
-
- # BUILD HERE
-
-cmake -DCMAKE_INSTALL_PREFIX=/usr/ \
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr/ \
-DUSE_QT5=ON \
- -DCMAKE_BUILD_TYPE=Release \
- -DBUILD_PLUGINS=${_plugins}
-
-make
+ -DCMAKE_BUILD_TYPE=Release
+ make
}
package() {
- cd "$srcdir/$_gitname-build/"
+ cd "$srcdir/${pkgname}"
make DESTDIR="$pkgdir/" install
-
}