summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-11-07 08:45:43 -0700
committerMark Wagie2020-11-07 08:45:43 -0700
commit97d265b9e939d07748762fe42c8dd46e18dd0064 (patch)
tree4477e582ee82b7afef136ff063b01fcc5c1aa511
parentb614c5e634b2c63550500a555cc59b0b8af646c8 (diff)
downloadaur-97d265b9e939d07748762fe42c8dd46e18dd0064.tar.gz
adjust dependencies
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD12
3 files changed, 21 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94f08b3258d3..39adc764213a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,28 @@
pkgbase = qomui-git
pkgdesc = Qt OpenVPN Management UI
pkgver = 0.8.2.r22.23650ab
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/corrad1nho/qomui
arch = x86_64
license = GPL3
makedepends = git
+ makedepends = python-setuptools
depends = python-pyqt5
depends = python-dbus
depends = openvpn
depends = stunnel
depends = bind-tools
- depends = dnsmasq
depends = python-psutil
depends = python-requests
depends = python-lxml
depends = python-beautifulsoup4
depends = python-pexpect
- depends = libcgroup
depends = wireguard-tools
depends = python-cryptography
+ optdepends = geoip: to identify server locations
+ optdepends = dnsmasq: required for bypassing OpenVPN
+ optdepends = libcgroup: required for bypassing OpenVPN
+ optdepends = iptables: required for bypassing OpenVPN
provides = qomui
conflicts = qomui
source = git+https://github.com/corrad1nho/qomui.git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index fe32910e899f..4b6410617aed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,19 @@
# Co-Maintainer: librewish <librewish at gmail dot com>
pkgname=qomui-git
pkgver=0.8.2.r22.23650ab
-pkgrel=1
+pkgrel=2
pkgdesc="Qt OpenVPN Management UI"
arch=('x86_64')
url="https://github.com/corrad1nho/qomui"
license=('GPL3')
-depends=('python-pyqt5' 'python-dbus' 'openvpn' 'stunnel' 'bind-tools' 'dnsmasq'
+depends=('python-pyqt5' 'python-dbus' 'openvpn' 'stunnel' 'bind-tools'
'python-psutil' 'python-requests' 'python-lxml' 'python-beautifulsoup4'
- 'python-pexpect' 'libcgroup' 'wireguard-tools' 'python-cryptography')
-makedepends=('git')
+ 'python-pexpect' 'wireguard-tools' 'python-cryptography')
+makedepends=('git' 'python-setuptools')
+optdepends=('geoip: to identify server locations'
+ 'dnsmasq: required for bypassing OpenVPN'
+ 'libcgroup: required for bypassing OpenVPN'
+ 'iptables: required for bypassing OpenVPN')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=('git+https://github.com/corrad1nho/qomui.git')