summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSven Schneider2012-04-06 17:09:12 +0200
committerSven Schneider2012-04-06 17:09:12 +0200
commit142061991f5b5176ace9cc0943a0d9a13473dda7 (patch)
tree844de39dbab51f3004c570d67bbfb208e09d3d43
downloadaur-142061991f5b5176ace9cc0943a0d9a13473dda7.tar.gz
added initial set of pkgbuilds
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD41
-rw-r--r--qonk.desktop13
-rw-r--r--qonk.patch81
-rw-r--r--qonk.pngbin0 -> 664 bytes
5 files changed, 157 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e5c740036f7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = qonk
+ pkgdesc = A small space build-and-conquer strategy game.
+ pkgver = 0.3.1
+ pkgrel = 2
+ url = http://qonk.sf.net
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = sdl_ttf
+ depends = sdl_gfx
+ depends = sdl_image
+ source = http://downloads.sourceforge.net/qonk/qonk-0.3.1.tar.gz
+ source = qonk.desktop
+ source = qonk.png
+ source = qonk.patch
+ md5sums = 9491980477ac5beb5bba6b8234d2ddfd
+ md5sums = ecce69a75740e0cac5e39cb59198f354
+ md5sums = 8f8d7b7d06111b102f6c1ad1aad290c0
+ md5sums = d479f49309f864e1db8e487fe062fc0d
+
+pkgname = qonk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c4ea2a0963a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Troels Kofoed Jacobsen <tkjacobsen@gmail.com>
+# Contributor: Sven Schneider <archlinux.sandmann@googlemail.com>
+
+pkgname=qonk
+pkgver=0.3.1
+pkgrel=2
+pkgdesc="A small space build-and-conquer strategy game."
+url="http://qonk.sf.net"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('sdl_ttf' 'sdl_gfx' 'sdl_image')
+source=(http://downloads.sourceforge.net/qonk/${pkgname}-${pkgver}.tar.gz
+ qonk.desktop
+ qonk.png
+ qonk.patch)
+md5sums=('9491980477ac5beb5bba6b8234d2ddfd'
+ 'ecce69a75740e0cac5e39cb59198f354'
+ '8f8d7b7d06111b102f6c1ad1aad290c0'
+ 'd479f49309f864e1db8e487fe062fc0d')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ patch -Np0 -i ${srcdir}/${pkgname}.patch
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ make DESTDIR="${pkgdir}/" install
+
+ # delete the guichan header file
+ rm -r ${pkgdir}/guichan
+
+ # install the .desktop file
+ install -Dm0644 ${srcdir}/qonk.desktop ${pkgdir}/usr/share/applications/qonk.desktop
+ install -Dm0644 ${srcdir}/qonk.png ${pkgdir}/usr/share/qonk/qonk.png
+}
diff --git a/qonk.desktop b/qonk.desktop
new file mode 100644
index 000000000000..452506752c16
--- /dev/null
+++ b/qonk.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Icon=/usr/share/qonk/qonk.png
+Exec=/usr/bin/qonk
+Terminal=false
+StartupNotify=false
+
+Name=Qonk
+GenericName=Space Game
+Comment=A small space build-and-conquer strategy game.
+
+Categories=Game;
diff --git a/qonk.patch b/qonk.patch
new file mode 100644
index 000000000000..b9ba9e96d2f8
--- /dev/null
+++ b/qonk.patch
@@ -0,0 +1,81 @@
+--- src/lisp/lisp.cpp 2007-09-14 07:43:03.000000000 +0200
++++ src/lisp/lisp.cpp~ 2010-09-26 18:05:38.000000000 +0200
+@@ -18,6 +18,7 @@
+ // along with this program; if not, write to the Free Software
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ #include "lisp.hpp"
++#include <cstdio>
+
+ namespace lisp
+ {
+
+--- src/lisp/lexer.cpp 2007-09-14 08:43:03.000000000 +0300
++++ src/lisp/lexer.cpp~ 2008-10-10 12:10:13.000000000 +0200
+@@ -19,6 +19,8 @@
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ #include <sstream>
+ #include <stdexcept>
++#include <cstring>
++#include <cstdio>
+
+ #include "lexer.hpp"
+ #include "translation.hpp"
+
+--- src/lisp/parser.cpp 2007-09-14 08:43:03.000000000 +0300
++++ src/lisp/parser.cpp~ 2008-10-10 12:13:01.000000000 +0200
+@@ -20,7 +20,7 @@
+ #include <sstream>
+ #include <stdexcept>
+ #include <fstream>
+-
++#include <cstring>
+ #include <cassert>
+
+ #include "parser.hpp"
+
+--- src/ui/menusystem.cpp 2007-09-14 08:43:03.000000000 +0300
++++ src/ui/menusystem.cpp~ 2008-10-10 12:15:30.000000000 +0200
+@@ -1,7 +1,7 @@
+ #include <iostream>
+
+-#include "settings.h"
+-#include "canvas.h"
++#include "../settings.h"
++#include "../canvas.h"
+
+ #include "menusystem.h"
+ #include "menu.h"
+
+--- src/menumanager.h 2007-09-14 08:43:03.000000000 +0300
++++ src/menumanager.h~ 2008-10-10 12:59:21.000000000 +0200
+@@ -7,6 +7,8 @@
+ #ifndef MENUMANAGER_H
+ #define MENUMANAGER_H
+
++#include "ui/menuaction.h"
++
+ class Main;
+
+ class ControlOptions;
+
+--- src/sdl_driver.cpp 2008-10-13 22:29:56.000000000 +0200
++++ src/sdl_driver.cpp~ 2008-10-13 22:29:40.000000000 +0200
+@@ -5,6 +5,7 @@
+ #include <SDL/SDL.h>
+ #include <SDL/SDL_ttf.h>
+ #include <cstdio>
++#include <cstdlib>
+
+ #include "sdl_driver.h"
+ #include "canvas.h"
+
+--- src/videooptions.cpp 2007-09-14 08:43:03.000000000 +0300
++++ src/videooptions.cpp~ 2008-10-10 12:46:10.000000000 +0200
+@@ -1,5 +1,6 @@
+ #include <vector>
+ #include <sstream>
++#include <algorithm>
+
+ #include <SDL/SDL.h>
+
+
diff --git a/qonk.png b/qonk.png
new file mode 100644
index 000000000000..d858b3bc89bb
--- /dev/null
+++ b/qonk.png
Binary files differ