summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTetsumi2015-09-18 20:39:22 +0200
committerTetsumi2015-09-18 20:55:50 +0200
commit801f1c95b4a735c5afe41bed42d215d620022b78 (patch)
tree99f27577cae49d7126ac956cb793f40bd20129ee
downloadaur-801f1c95b4a735c5afe41bed42d215d620022b78.tar.gz
initial commit.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD54
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..544e9e8f9ec6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = qore
+ pkgdesc = Qore is a high-level, general-purpose, interpreted, dynamic programming language
+ pkgver = 0.8.11
+ pkgrel = 1
+ url = http://www.qore.org/
+ arch = i686
+ arch = x86_64
+ license = GPL2,
+ license = LGPL2
+ depends = flex
+ depends = openssl
+ depends = pcre
+ depends = bzip2
+ depends = zlib
+ source = http://sourceforge.net/projects/qore/files/qore/0.8.11/qore-0.8.11.tar.bz2
+ md5sums = 483510cdcb6338ff6cb892cc29a98a63
+
+pkgname = qore
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b8e5a6f54afb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Tetsumi <tetsumi@vmail.me>
+# Contributor: Boris Shomodjvarac <spam AT shomodj DOT com>
+
+pkgname=qore
+pkgver=0.8.11
+pkgrel=1
+epoch=
+pkgdesc="Qore is a high-level, general-purpose, interpreted, dynamic programming language"
+arch=("i686" "x86_64")
+url="http://www.qore.org/"
+license=('GPL2', "LGPL2")
+groups=()
+depends=("flex" "openssl" "pcre" "bzip2" "zlib")
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("http://sourceforge.net/projects/qore/files/$pkgname/$pkgver/${pkgname}-${pkgver}.tar.bz2")
+md5sums=('483510cdcb6338ff6cb892cc29a98a63')
+noextract=()
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ sed 's/LIBSUFFIX=64/LIBSUFFIX=""/g' configure -i
+
+ _CONFIGURE_OPTS="--prefix=/usr --disable-static --disable-debug"
+ [ "$CARCH" = "x86_64" ] && _CONFIGURE_OPTS="$_CONFIGURE_OPTS --enable-64bit"
+
+ echo "./configure $_CONFIGURE_OPTS"
+ ./configure $_CONFIGURE_OPTS
+ make
+}
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make -k check
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+
+
+
+# vim:set ts=2 sw=2 et:
+