summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmmon Smith2016-06-20 14:21:17 -0700
committerAmmon Smith2016-06-20 14:21:17 -0700
commit3d125e2fbfbbd8546c86bcf07ccaf1693a076cd6 (patch)
tree8262ddcd7e8aa6446ac704e4c626379b2148ea11
downloadaur-3d125e2fbfbbd8546c86bcf07ccaf1693a076cd6.tar.gz
Initial commit.
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD38
-rw-r--r--qotd.install14
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2a700c21c306
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Mon Jun 20 21:21:02 UTC 2016
+pkgbase = qotd
+ pkgdesc = A simple RFC 865-compliant QOTD (quote of the day) daemon.
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = https://gitlab.com/ammongit/qotd
+ install = qotd.install
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = gcc
+ makedepends = ghostscript
+ makedepends = gzip
+ depends = glibc
+ provides = qotd
+ conflicts = qotd
+ backup = etc/qotd.conf
+ source = git+https://gitlab.com/ammongit/qotd.git
+ sha256sums = SKIP
+
+pkgname = qotd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93015b437915
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Ammon Smith <ammon.i.smith@gmail.com>
+
+_pkgname=qotd
+pkgname="$_pkgname"
+pkgver=0.5.0
+pkgrel=1
+pkgdesc="A simple RFC 865-compliant QOTD (quote of the day) daemon."
+arch=('any')
+url="https://gitlab.com/ammongit/$_pkgname"
+license=('GPL')
+depends=('glibc')
+makedepends=('git' 'gcc' 'ghostscript' 'gzip')
+optdepends=()
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+options=()
+install="$pkgname.install"
+source=("git+https://gitlab.com/ammongit/$_pkgname.git")
+sha256sums=('SKIP')
+backup=('etc/qotd.conf')
+
+build() {
+ cd "$srcdir/$_pkgname"
+
+ # Go to the correct commit for this release
+ git reset --hard "$(git rev-parse "v$pkgver")"
+
+ # Compile sources
+ make release
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make ROOT="$pkgdir" SYSTEMD=1 install
+ install -D -m644 "doc/$_pkgname.pdf" "$pkgdir/usr/share/doc/$_pkgname/$_pkgname.pdf"
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+}
+
diff --git a/qotd.install b/qotd.install
new file mode 100644
index 000000000000..e8fa8fc7c06b
--- /dev/null
+++ b/qotd.install
@@ -0,0 +1,14 @@
+post_install() {
+ systemctl daemon-reload
+
+ echo 'Start the new systemd unit:'
+ echo 'sudo systemctl enable --now qotd.service'
+}
+
+post_upgrade() {
+ systemctl daemon-reload
+
+ echo 'Restart the qotd systemd unit:'
+ echo 'sudo systemctl restart qotd.service'
+}
+