summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Reichold2015-11-24 16:35:40 +0100
committerAdam Reichold2015-11-24 16:35:40 +0100
commit09ff617a151dbce3ec928463349d602328b1f362 (patch)
tree5e8e608eea550779852d5d880232dc60c9205d19
parentaeaa8965b5ba90ab3c2aafa37afcb2847898f5af (diff)
downloadaur-09ff617a151dbce3ec928463349d602328b1f362.tar.gz
Track dependency on texlive-bin if linked against system SyncTeX parser.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
2 files changed, 16 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa7a6e92ff20..803fd5788237 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qpdfview
pkgdesc = A tabbed PDF viewer using the poppler library.
pkgver = 0.4.16
- pkgrel = 2
+ pkgrel = 3
url = https://launchpad.net/qpdfview
install = qpdfview.install
arch = i686
@@ -14,10 +14,17 @@ pkgbase = qpdfview
depends = qt5-svg
depends = desktop-file-utils
depends = hicolor-icon-theme
+ optdepends = texlive-bin: for shared SyncTeX parser library (required at build time)
optdepends = libspectre: for PostScript support (required at build time)
optdepends = djvulibre: for DjVu support (required at build time)
source = https://launchpad.net/qpdfview/trunk/0.4.16/+download/qpdfview-0.4.16.tar.gz
sha256sums = fad416e8fefc3057fa1b8d12d964c7eccd16dffe0307a0d6e9d55a543294da7f
pkgname = qpdfview
+ depends = libcups
+ depends = poppler-qt5
+ depends = qt5-svg
+ depends = desktop-file-utils
+ depends = hicolor-icon-theme
+ depends = texlive-bin
diff --git a/PKGBUILD b/PKGBUILD
index 5a19d0a14a7b..10822987b8d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,15 @@
pkgname=qpdfview
pkgver=0.4.16
-pkgrel=2
+pkgrel=3
pkgdesc='A tabbed PDF viewer using the poppler library.'
arch=('i686' 'x86_64' 'armv7h')
url='https://launchpad.net/qpdfview'
license=('GPL2')
depends=('libcups' 'poppler-qt5' 'qt5-svg' 'desktop-file-utils' 'hicolor-icon-theme')
-optdepends=('libspectre: for PostScript support (required at build time)' 'djvulibre: for DjVu support (required at build time)')
+optdepends=('texlive-bin: for shared SyncTeX parser library (required at build time)'
+ 'libspectre: for PostScript support (required at build time)'
+ 'djvulibre: for DjVu support (required at build time)')
makedepends=('qt5-tools')
install='qpdfview.install'
source=("https://launchpad.net/$pkgname/trunk/$pkgver/+download/$pkgname-$pkgver.tar.gz")
@@ -34,5 +36,9 @@ package() {
cd "$srcdir/$pkgname-$pkgver"
make "INSTALL_ROOT=$pkgdir" install
+
+ if pkg-config --exists synctex; then
+ depends=("${depends[@]}" 'texlive-bin')
+ fi
}