summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Reichold2015-06-10 18:39:29 +0200
committerAdam Reichold2015-06-10 18:39:29 +0200
commit6b2447e0ced6b845bf5ad90201c207781755e3ed (patch)
tree74ac18f35519b2195765c315df73c8d84fb1bec4
downloadaur-6b2447e0ced6b845bf5ad90201c207781755e3ed.tar.gz
Initial import
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD53
-rw-r--r--qpdfview.install13
3 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa2d043d542e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = qpdfview-bzr
+ pkgdesc = A tabbed PDF viewer using the poppler library. (development version)
+ pkgver = 1924
+ pkgrel = 1
+ url = https://launchpad.net/qpdfview
+ install = qpdfview.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = bzr
+ makedepends = qt5-tools
+ depends = libcups
+ depends = qt5-svg
+ depends = desktop-file-utils
+ depends = hicolor-icon-theme
+ optdepends = poppler-qt5: for PDF support (required at build time)
+ optdepends = libspectre: for PostScript support (required at build time)
+ optdepends = djvulibre: for DjVu support (required at build time)
+ optdepends = mupdf: for PDF support (required at build time)
+ conflicts = qpdfview
+ source = qpdfview::bzr+http://bazaar.launchpad.net/~adamreichold/qpdfview/trunk/
+ md5sums = SKIP
+
+pkgname = qpdfview-bzr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d007eaf3c3c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Adam Reichold <adam.reichold@t-online.de>
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=qpdfview-bzr
+pkgver=1924
+pkgrel=1
+pkgdesc='A tabbed PDF viewer using the poppler library. (development version)'
+arch=('i686' 'x86_64')
+url='https://launchpad.net/qpdfview'
+license=('GPL2')
+depends=('libcups' 'qt5-svg' 'desktop-file-utils' 'hicolor-icon-theme')
+optdepends=('poppler-qt5: for PDF support (required at build time)' 'libspectre: for PostScript support (required at build time)' 'djvulibre: for DjVu support (required at build time)' 'mupdf: for PDF support (required at build time)')
+makedepends=('bzr' 'qt5-tools')
+conflicts=('qpdfview')
+install='qpdfview.install'
+source=('qpdfview::bzr+http://bazaar.launchpad.net/~adamreichold/qpdfview/trunk/')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/qpdfview"
+
+ bzr revno
+}
+
+build() {
+ cd "$srcdir/qpdfview"
+
+if ! pkg-config --exists poppler-qt5; then
+ local config="$config without_pdf"
+fi
+
+ if ! pkg-config --exists libspectre; then
+ local config="$config without_ps"
+ fi
+
+ if ! pkg-config --exists ddjvuapi; then
+ local config="$config without_djvu"
+ fi
+
+if [ -f /usr/lib/libmupdf.a ]; then
+ local config="$config with_fitz"
+fi
+
+ lrelease-qt5 qpdfview.pro qpdfview.pro
+ qmake-qt5 "CONFIG+=$config" qpdfview.pro
+ make
+}
+
+package() {
+ cd "$srcdir/qpdfview"
+
+ make "INSTALL_ROOT=$pkgdir" install
+}
diff --git a/qpdfview.install b/qpdfview.install
new file mode 100644
index 000000000000..e323b08b1c73
--- /dev/null
+++ b/qpdfview.install
@@ -0,0 +1,13 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &>/dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+