summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormato7d52016-07-25 22:18:29 +0200
committermato7d52016-07-25 22:18:29 +0200
commita54e857f6188f98a829f65054ea7d4eecc7b814a (patch)
tree4e523a558fd8b422a3aff20b4af075731e96be21
downloadaur-a54e857f6188f98a829f65054ea7d4eecc7b814a.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..21ce656c5e8c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = qpdfwalker-git
+ pkgdesc = Tool for browsing hierarchy of low level objects in a PDF file.
+ pkgver = dev1
+ pkgrel = 1
+ url = https://github.com/mato7d5/qpdfwalker
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = poppler
+ depends = qt5-base
+ source = git+https://github.com/mato7d5/qpdfwalker.git
+ sha256sums = SKIP
+
+pkgname = qpdfwalker-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..467abf87f955
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Martin Mancuska <martin@borg.sk>
+
+_pkgname=qpdfwalker
+pkgname=$_pkgname-git
+pkgver=dev1
+pkgrel=1
+pkgdesc="Tool for browsing hierarchy of low level objects in a PDF file."
+arch=('i686' 'x86_64')
+url="https://github.com/mato7d5/$_pkgname"
+license=('GPL3')
+depends=('poppler' 'qt5-base')
+makedepends=('git')
+source=("git+https://github.com/mato7d5/$_pkgname.git")
+sha256sums=("SKIP")
+
+build() {
+ cd "$srcdir/$_pkgname"
+ qmake-qt5 qpdfwalker.pro
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -Dm755 qpdfwalker "${pkgdir}/usr/local/bin/qpdfwalker"
+}