summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCôme Bernigaud2015-06-08 20:40:07 +0200
committerCôme Bernigaud2015-06-08 20:40:07 +0200
commitdb8e2024dfdee4e6de567bc31041912e11ee7c57 (patch)
treeb13ac8e5e59ffe8513ea7d7402da748796e8433b
downloadaur-db8e2024dfdee4e6de567bc31041912e11ee7c57.tar.gz
First upload to aur4
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD34
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..136406fceedf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = qphotobooth-git
+ pkgdesc = Photo booth implementation for parties.
+ pkgver = 929f8d6
+ pkgrel = 1
+ url = http://projects.haxx.es/p/qphotobooth/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ makedepends = cmake
+ depends = opencv
+ depends = qt5-base
+ depends = qt5-sensors
+ depends = qt5-webkit
+ depends = qt5-multimedia
+ provides = qphotobooth
+ replaces = qphotobooth
+ source = git://haxx.es/qphotobooth.git
+ sha256sums = SKIP
+
+pkgname = qphotobooth-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..afb71835f9e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Contributor: VirtualTam
+# Maintainer: MCMic <come.bernigaud@laposte.net>
+
+pkgname=qphotobooth-git
+pkgver=929f8d6
+pkgrel=1
+pkgdesc="Photo booth implementation for parties."
+arch=('i686' 'x86_64')
+url="http://projects.haxx.es/p/qphotobooth/"
+license=('BSD')
+depends=('opencv' 'qt5-base' 'qt5-sensors' 'qt5-webkit' 'qt5-multimedia')
+makedepends=('git' 'cmake')
+conflicts=()
+provides=('qphotobooth')
+replaces=('qphotobooth')
+_gitname="qphotobooth"
+source=(git://haxx.es/qphotobooth.git)
+sha256sums=(SKIP)
+
+pkgver() {
+ cd ${_gitname}
+ git describe --always | sed 's|-|.|g'
+}
+
+build(){
+ cd ${_gitname}
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+package() {
+ cd ${_gitname}/
+ make install DESTDIR=$pkgdir
+}