summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Carr2016-01-08 14:51:15 -0800
committerDonald Carr2016-01-08 16:58:35 -0800
commit4b4e989d6f1734131d951e638683849dedda3c63 (patch)
treeeb3823f46a3fff7d82411cb1419dad8173595908
parent1e5417b3f7787ec184b695283b0b0d62181ce6ee (diff)
downloadaur-4b4e989d6f1734131d951e638683849dedda3c63.tar.gz
Change pkgname to reduce pi1/pi2 delta to one field
Include upstream qtquickcontrols2 which builds with float QWebEngine would be useful on the Raspberry PI 2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD31
-rw-r--r--PKGBUILD.libs (renamed from qpii-libs-PKGBUILD)4
3 files changed, 27 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7e7cd7f80789..5aab8b595cfe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Jan 8 22:52:07 UTC 2016
+# Sat Jan 9 00:58:02 UTC 2016
pkgbase = qpi2
pkgdesc = Cross compile Qt for the Raspberry Pi2
pkgver = 5.6.0
- pkgrel = 4
+ pkgrel = 5
url = http://www.qt.io
arch = x86_64
license = LGPL3
@@ -12,9 +12,11 @@ pkgbase = qpi2
makedepends = gcc
makedepends = qpi-toolchain
options = !strip
+ source = git://github.com/qtproject/qtquickcontrols2.git
source = git://github.com/sirspudd/mkspecs.git
source = https://download.qt.io/development_releases/qt/5.6/5.6.0-beta/single/qt-everywhere-opensource-src-5.6.0-beta.tar.gz
sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = d69103ec34b3775edfa47581b14ee9a20789d4b0d7d26220fb92f2cd32eb06f9
pkgname = qpi2
diff --git a/PKGBUILD b/PKGBUILD
index 07ae2305ea48..f8922831604a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -32,14 +32,14 @@ _pkgver=${pkgver}-beta
_baseprefix=/opt
_installprefix=${_baseprefix}/qt-${_pkgver}-rpi${_piver}
_pipkgname=qt-everywhere-opensource-src-${_pkgver}
-pkgrel=4
+pkgrel=5
pkgdesc="Cross compile Qt for the Raspberry Pi${_piver}"
arch=("x86_64")
url="http://www.qt.io"
license=("LGPL3")
makedepends=("git" "pkgconfig" "gcc" "qpi-toolchain")
-source=("git://github.com/sirspudd/mkspecs.git" "https://download.qt.io/development_releases/qt/5.6/${_pkgver}/single/${_pipkgname}.tar.gz")
-sha256sums=("SKIP" "d69103ec34b3775edfa47581b14ee9a20789d4b0d7d26220fb92f2cd32eb06f9")
+source=("git://github.com/qtproject/qtquickcontrols2.git" "git://github.com/sirspudd/mkspecs.git" "https://download.qt.io/development_releases/qt/5.6/${_pkgver}/single/${_pipkgname}.tar.gz")
+sha256sums=("SKIP" "SKIP" "d69103ec34b3775edfa47581b14ee9a20789d4b0d7d26220fb92f2cd32eb06f9")
options=('!strip')
build() {
@@ -82,8 +82,6 @@ build() {
-no-xcb \
\
-skip qtscript \
- -skip qtwebengine \
- -skip qtwebchannel \
-skip qtwayland \
-skip qtquickcontrols2 \
\
@@ -96,9 +94,15 @@ build() {
# regrettably required, as qtwayland barfs on shadow builds
# as private header paths not included: no clue how to fix, bypassing
- cp -r ${_srcdir}/qtwayland .
- cd qtwayland
- ../qtbase/bin/qmake CONFIG+=wayland-compositor
+ cp -r "${_srcdir}/qtwayland" "${_bindir}"
+ cd "${_bindir}/qtwayland"
+ ${_bindir}/qtbase/bin/qmake CONFIG+=wayland-compositor
+ make
+
+ # temp hack
+ cp -r "${srcdir}/qtquickcontrols2" "${_bindir}"
+ cd "${_bindir}/qtquickcontrols2"
+ ${_bindir}/qtbase/bin/qmake
make
}
@@ -115,7 +119,11 @@ package() {
INSTALL_ROOT="$pkgdir" make install
# regrettably required
- cd "${_bindir}"/qtwayland
+ cd "${_bindir}/qtwayland"
+ INSTALL_ROOT="$pkgdir" make install
+
+ # temp hack
+ cd "${_bindir}/qtquickcontrols2"
INSTALL_ROOT="$pkgdir" make install
# Qt is now installed to $pkgdir/$sysroot/$prefix
@@ -127,9 +135,12 @@ package() {
rm -Rf ${_libspkgdir}
mkdir -p ${_libspkgdir}
- cp ${startdir}/${_libspkgname}-PKGBUILD ${_libspkgbuild}
+ cp ${startdir}/PKGBUILD.libs ${_libspkgbuild}
mv "${pkgdir}/${_sysroot}/${_baseprefix}" ${_libspkgdir}
# set correct libs version
+ sed -i "s/libspackagename/${_libspkgname}/" ${_libspkgbuild}
+ sed -i "s/libspiversion/${_piver}/" ${_libspkgbuild}
+
sed -i "s/6.6.6/${pkgver}/" ${_libspkgbuild}
mkdir -p ${_pkgprofiled}
diff --git a/qpii-libs-PKGBUILD b/PKGBUILD.libs
index 119c91e1170e..f6240f53016a 100644
--- a/qpii-libs-PKGBUILD
+++ b/PKGBUILD.libs
@@ -1,9 +1,9 @@
# Maintainer: Donald Carr <sirspudd@gmail.com>
-pkgname=qpii-libs
+pkgname=libspackagename
pkgver=6.6.6
pkgrel=1
-pkgdesc="Qt ${pkgver} libs for the ${_piver}"
+pkgdesc="Qt ${pkgver} libs cross compiled for the Raspberry Pi libspiversion"
# I don't know how to set this correct for cross architecture builds
arch=("any")
url="http://www.qt.io"