summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShadowsith2018-07-10 01:17:01 +0200
committerShadowsith2018-07-10 01:17:01 +0200
commit02d17972d139b69c896f3e16625cc17bc08d1cb0 (patch)
tree73c9d87accc63b9ce30cd299237079491603f9d4
downloadaur-02d17972d139b69c896f3e16625cc17bc08d1cb0.tar.gz
adding new program QPicoSpeaker from my GitHub repository to the AUR
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD35
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..85f4f84e4ea6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = qpicospeaker-git
+ pkgdesc = Qt GUI for the svox-pico text-to-speech engine
+ pkgver = git
+ pkgrel = 1
+ url = https://github.com/Shadowsith/qpicospeaker
+ arch = i686
+ arch = x86_64
+ makedepends = qt5-base
+ depends = sox
+ depends = svox-pico-bin
+ source = git+https://github.com/Shadowsith/qpicospeaker
+ sha256sums = SKIP
+
+pkgname = qpicospeaker-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cddc48eda1a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Shadowsith <philip.mayer@shadowsith.de>
+
+pkgname=qpicospeaker-git
+pkgver=git
+pkgrel=1
+pkgdesc='Qt GUI for the svox-pico text-to-speech engine'
+arch=('i686' 'x86_64')
+url='https://github.com/Shadowsith/qpicospeaker'
+licence=('MIT')
+depends=('sox' 'svox-pico-bin')
+makedepends=(qt5-base)
+optdepends=()
+provides=('')
+backup=("")
+install=
+source=("git+https://github.com/Shadowsith/qpicospeaker")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd build
+}
+
+build() {
+ make
+}
+
+package() {
+ make install
+}
+