summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShadowsith2018-07-11 23:47:48 +0200
committerShadowsith2018-07-11 23:47:48 +0200
commit3ec57f107b66602a11c0d324829e740e7e2e5514 (patch)
tree2fb3d5008307ec4288e0e50d47ca9a87b2cebadd
parent5159936a350e0effe1cd60fbd1191cfea59f84da (diff)
downloadaur-3ec57f107b66602a11c0d324829e740e7e2e5514.tar.gz
changed PKGBUILD to handle newest git version
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ecabc4c7dfeb..3563d95ca14f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qpicospeaker-git
pkgdesc = Qt GUI for the svox-pico text-to-speech engine
- pkgver = r15.5331623
+ pkgver = r19.f92a59b
pkgrel = 1
url = https://github.com/Shadowsith/qpicospeaker
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index aa4c806054de..6b92a8472b50 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=qpicospeaker-git
pkgsrc=qpicospeaker
-pkgver=r15.5331623
+pkgver=r19.f92a59b
pkgrel=1
pkgdesc='Qt GUI for the svox-pico text-to-speech engine'
arch=('i686' 'x86_64')
@@ -35,11 +35,13 @@ pkgver() {
build() {
cd build
- qmake ../qpicospeaker/qpicospeaker/qpicospeaker.pro
+ qmake ../qpicospeaker/qpicospeaker.pro
make
}
package() {
install -Dm755 ./build/qpicospeaker "$pkgdir/usr/bin/qpicospeaker"
- install -Dm666 ./qpicospeaker/icons/qpicospeaker.png "$pkgdir$HOME/.local/share/icons/hicolor/32x32/apps/qpicospeaker.png"
+ install -Dm666 ./qpicospeaker/data/icons/32x32/qpicospeaker.png "$pkgdir/usr/share/icons/hicolor/32x32/qpicospeaker.png"
+ install -d -Dm666 ./qpicospeaker "$pkgdir/usr/share/qpicospeaker"
+ install -Dm666 ./qpicospeaker/data/desktop/qpicospeaker.desktop "$pkgdir/usr/share/applications/qpicospeaker.desktop"
}