summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShadowsith2019-07-26 23:12:42 +0200
committerShadowsith2019-07-26 23:12:42 +0200
commit558735a9c1ad6a0236139538cf6d1a10bbbbef74 (patch)
tree1e96d401163d928bfac24ff99693c55a95487020
parent9639e1e675a5fbca74fa8acd1f07b8279580d014 (diff)
downloadaur-558735a9c1ad6a0236139538cf6d1a10bbbbef74.tar.gz
adding all needed git submodules before building the software
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD3
2 files changed, 3 insertions, 1 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6e92f57d4647
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+tags
diff --git a/PKGBUILD b/PKGBUILD
index 88a7916cc5c4..ab9720b3efe9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgsrc=qpicospeaker
pkgver=r21.69214be
pkgrel=1
pkgdesc='Qt GUI for the svox-pico text-to-speech engine'
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'aarch64' 'arm')
url='https://github.com/Shadowsith/qpicospeaker'
licence=('MIT')
depends=('sox' 'svox-pico-bin')
@@ -34,6 +34,7 @@ pkgver() {
}
build() {
+ git submodule update --init --recursive
cd build
qmake ../qpicospeaker/qpicospeaker.pro
make