summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShadowsith2018-07-10 01:56:14 +0200
committerShadowsith2018-07-10 01:56:14 +0200
commitb176c9f8f55d288e2cbf60b949d98230aabc3927 (patch)
treecbce9b764dcc56ec76bbe662d60c803448a78ab5
parent02d17972d139b69c896f3e16625cc17bc08d1cb0 (diff)
downloadaur-b176c9f8f55d288e2cbf60b949d98230aabc3927.tar.gz
PKBUILD errors fixed, .SRCINFO changed
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 85f4f84e4ea6..7ad5f6973447 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = qpicospeaker-git
+pkgbase = qpicospeaker
pkgdesc = Qt GUI for the svox-pico text-to-speech engine
- pkgver = git
+ pkgver = r10.ec83c9a
pkgrel = 1
url = https://github.com/Shadowsith/qpicospeaker
arch = i686
@@ -11,5 +11,5 @@ pkgbase = qpicospeaker-git
source = git+https://github.com/Shadowsith/qpicospeaker
sha256sums = SKIP
-pkgname = qpicospeaker-git
+pkgname = qpicospeaker
diff --git a/PKGBUILD b/PKGBUILD
index cddc48eda1a4..f575a9cd9088 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Shadowsith <philip.mayer@shadowsith.de>
-pkgname=qpicospeaker-git
-pkgver=git
+pkgname=qpicospeaker
+pkgver=r10.ec83c9a
pkgrel=1
pkgdesc='Qt GUI for the svox-pico text-to-speech engine'
arch=('i686' 'x86_64')
@@ -18,18 +18,15 @@ sha256sums=('SKIP')
pkgver() {
cd "$pkgname"
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
-prepare() {
- cd build
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- make
+ pwd
+ make -C ./qpicospeaker/build
}
package() {
- make install
+ make install -C ./qpicospeaker/build
}