summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOleksandr Natalenko2017-07-15 15:47:59 +0200
committerOleksandr Natalenko2017-07-15 15:47:59 +0200
commit8b9a9027c9d373983ceb91ef621d10a0c4173a38 (patch)
tree657da86581d20d0ecdf499720843825861ae9a6a
parenta96225a1c0f7957155033f2b0d9ac4cd2f2427d1 (diff)
downloadaur-8b9a9027c9d373983ceb91ef621d10a0c4173a38.tar.gz
update to v0.17.0
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD43
3 files changed, 40 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c94fa05d875a..08f8166c97fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Sat Jul 15 13:47:33 UTC 2017
pkgbase = qpid-proton
pkgdesc = Proton is a high-performance, lightweight messaging library
- pkgver = 0.15.0
+ pkgver = 0.17.0
pkgrel = 1
url = https://qpid.apache.org/releases/
arch = i686
@@ -12,8 +14,9 @@ pkgbase = qpid-proton
makedepends = cmake
makedepends = swig
depends = python2
- source = https://www-us.apache.org/dist/qpid/proton/0.15.0/qpid-proton-0.15.0.tar.gz
- sha1sums = 7c85f9a76a33c1f22dbef22dc194f315261a6a02
+ depends = openssl-1.0
+ source = https://www-us.apache.org/dist/qpid/proton/0.17.0/qpid-proton-0.17.0.tar.gz
+ sha256sums = 6ffd26d3d0e495bfdb5d9fefc5349954e6105ea18cc4bb191161d27742c5a01a
pkgname = qpid-proton
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b20752a93bec
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.tar.xz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
index c866bc9acb5b..b40417eea537 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,47 @@
-# Maintainer: Florian Schweikert <kelvan at ist-total.org>
+# Maintainer: Oleksandr Natalenko <oleksandr@natalenko.name>
+# Former maintainer: Florian Schweikert <kelvan at ist-total.org>
pkgname=qpid-proton
-pkgver=0.15.0
+pkgver=0.17.0
pkgrel=1
pkgdesc="Proton is a high-performance, lightweight messaging library"
arch=('i686' 'x86_64' 'armv7h')
url="https://qpid.apache.org/releases/"
license=('APACHE')
-depends=('python2')
+depends=('python2' 'openssl-1.0')
makedepends=('util-linux' 'python2' 'cmake' 'swig')
optdepends=()
source=("https://www-us.apache.org/dist/qpid/proton/$pkgver/$pkgname-$pkgver.tar.gz")
-sha1sums=('7c85f9a76a33c1f22dbef22dc194f315261a6a02')
+sha256sums=('6ffd26d3d0e495bfdb5d9fefc5349954e6105ea18cc4bb191161d27742c5a01a')
build() {
- cd "${srcdir}/qpid-proton-${pkgver}"
- mkdir build
- cd build
- cmake .. -DSYSINSTALL_BINDINGS=ON -DPYTHON_EXECUTABLE=/usr/bin/python2.7 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python2.7/ \
- -DPYTHON_LIBRARY=/lib/libpython2.7.so -DCMAKE_INSTALL_PREFIX=/usr \
- -DBUILD_PHP=OFF -DBUILD_RUBY=OFF -DBUILD_PERL=OFF -DBUILD_JAVA=OFF -DBUILD_PYTHON=ON \
- -DCMAKE_INSTALL_LIBDIR=/lib -DLIB_SUFFIX=""
- make
+ cd "${srcdir}/qpid-proton-${pkgver}"
+
+ mkdir build
+ cd build
+
+ cmake .. \
+ -DSYSINSTALL_BINDINGS=ON \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2.7 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7/ \
+ -DPYTHON_LIBRARY=/lib/libpython2.7.so \
+ -DOPENSSL_SSL_LIBRARY=/usr/lib/libssl.so.1.0.0 \
+ -DOPENSSL_CRYPTO_LIBRARY=/usr/lib/libcrypto.so.1.0.0 \
+ -DOPENSSL_INCLUDE_DIR=/usr/include/openssl-1.0 \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_PHP=OFF \
+ -DBUILD_RUBY=OFF \
+ -DBUILD_PERL=OFF \
+ -DBUILD_JAVA=OFF \
+ -DBUILD_PYTHON=ON \
+ -DCMAKE_INSTALL_LIBDIR=/lib \
+ -DLIB_SUFFIX=""
+
+ cmake --build .
}
package() {
cd "${srcdir}/qpid-proton-${pkgver}/build"
+
make DESTDIR="${pkgdir}/" install
}
+