summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Carr2018-09-17 17:19:45 -0700
committerDonald Carr2018-09-17 17:20:19 -0700
commit01b576eaba98dbfbfc4fc7695e5f3a89b2eea952 (patch)
treea7abbbc452a6b8ce14dc9bf1a909f505b214d7ec
parentce4aff52af48d67977ad67aab179fc519a6073d4 (diff)
downloadaur-01b576eaba98dbfbfc4fc7695e5f3a89b2eea952.tar.gz
Update recipe as per Skycoder42
Change-Id: I10688fc56d89d7504762866359b61744c67534a8
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8dbf0f69a279..18c47740c23e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Fri Jun 1 18:45:25 UTC 2018
+# Tue Sep 18 00:20:15 UTC 2018
pkgbase = qpm
pkgdesc = Qt Package Manager
pkgver = v0.11.0
diff --git a/PKGBUILD b/PKGBUILD
index a6b66f021468..b7eb7151d275 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,11 +29,11 @@ build() {
cd $_qpm_dir
local git_sha1=$(git rev-parse HEAD | cut -c1-8)
- cd ${startdir}
- export GOPATH="$startdir"
+ cd $srcdir
+ export GOPATH="$srcdir/.."
go build -ldflags "-X qpm.io/qpm/core.Version=${pkgver} -X qpm.io/qpm/core.Build=${git_sha1}" qpm.io/qpm
}
package() {
- install -Dm755 "${startdir}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
}