summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Carr2018-09-17 17:44:23 -0700
committerDonald Carr2018-09-17 17:47:14 -0700
commit03a7150da83df769e8ca330f393e005149bde390 (patch)
treeaff9a8f72551405825cde5b3cdc836398fda7e4f
parent3981d9ae6241e6e7f4d8ff5d48e8301ed9a2403e (diff)
downloadaur-03a7150da83df769e8ca330f393e005149bde390.tar.gz
Remove references to startdir
Change-Id: Ifd68cc103420de2a16e2c091222d8484a811c652
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03fdfcd68ce1..ce8dc755098b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Fri Jun 1 18:51:54 UTC 2018
+# Tue Sep 18 00:46:58 UTC 2018
pkgbase = qpm-git
pkgdesc = Qt Package Manager
pkgver = v0.11.0.r2.g7c41bcc
diff --git a/PKGBUILD b/PKGBUILD
index b56e2cad072f..419a169124b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -36,11 +36,12 @@ build() {
cd $_qpm_dir
local git_sha1=$(git rev-parse HEAD | cut -c1-8)
- cd ${startdir}
- export GOPATH="$startdir"
+ cd $srcdir
+ export GOPATH="$srcdir/.."
go build -ldflags "-X qpm.io/qpm/core.Version=${pkgver} -X qpm.io/qpm/core.Build=${git_sha1}" qpm.io/qpm
}
package() {
- install -Dm755 "${startdir}/qpm" "${pkgdir}/usr/bin/${pkgname}"
+ cd $srcdir
+ install -Dm755 qpm "${pkgdir}/usr/bin/${pkgname}"
}