summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Witschel2022-03-12 10:47:40 +0000
committerJonas Witschel2022-03-12 10:47:40 +0000
commit664cc902772d6563a73edb9e6358b4ecc9958564 (patch)
tree595db9f413db47e10d31577934b901e2c7684dcc
downloadaur-664cc902772d6563a73edb9e6358b4ecc9958564.tar.gz
newpkg: qpwgraph (PipeWire Graph Qt GUI Interface)
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d9267ae8eb2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Jonas Witschel <diabonas@archlinux.org>
+pkgname=qpwgraph
+pkgver=0.2.3
+pkgrel=1
+pkgdesc='PipeWire Graph Qt GUI Interface'
+arch=('x86_64')
+url='https://gitlab.freedesktop.org/rncbc/qpwgraph'
+license=('GPL')
+depends=('alsa-lib' 'pipewire' 'qt6-base')
+makedepends=('cmake')
+source=("$url/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
+sha512sums=('1c167f569fb3345edb0402bccc220b296a3c54f78ab141cb2280caa6576726ffe7e4ee49c702abb1e6368ae8c173684645f7fbfbd39511868e14631af60b5dfd')
+
+build() {
+ cmake -B build -S "$pkgname-v$pkgver" -DCMAKE_INSTALL_PREFIX=/usr -DCONFIG_WAYLAND=ON
+ make -C build
+}
+
+package() {
+ make -C build DESTDIR="$pkgdir" install
+}