summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan Farley2021-01-03 11:37:36 -0600
committerRyan Farley2021-01-03 11:37:36 -0600
commit19951681aa4cb5c72b534ade48babdb0745aeeda (patch)
tree251acc817716efb6e5c60f26d7cc567d07766588
parente675d144147e967f58035381505040a91934a15f (diff)
downloadaur-19951681aa4cb5c72b534ade48babdb0745aeeda.tar.gz
update to 0.8.1
-rw-r--r--.SRCINFO8
-rw-r--r--0001-add-needed-qiodevice-include.patch24
-rw-r--r--PKGBUILD12
3 files changed, 6 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0f540c4a6e9..a32478d65308 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
pkgbase = qpxtool
pkgdesc = Allows better controll over optical drives to include QChecks and optimization settings.
- pkgver = 0.8.0
+ pkgver = 0.8.1
pkgrel = 1
url = http://qpxtool.sourceforge.net/
arch = x86_64
license = GPL
depends = qt5-base
- source = http://downloads.sourceforge.net/sourceforge/qpxtool/qpxtool-0.8.0.tar.bz2
- source = 0001-add-needed-qiodevice-include.patch
- md5sums = f4b09f8d5aa533f680c8bcce19c1072e
- md5sums = e494a876eea1078e822d850c8f477487
+ source = http://downloads.sourceforge.net/sourceforge/qpxtool/qpxtool-0.8.1.tar.bz2
+ md5sums = 33f210de24ef8dd7c7adac6b41ac8328
pkgname = qpxtool
diff --git a/0001-add-needed-qiodevice-include.patch b/0001-add-needed-qiodevice-include.patch
deleted file mode 100644
index b1ebeaef1ea9..000000000000
--- a/0001-add-needed-qiodevice-include.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From a22962a46799ed894b29561a961736fec47830c1 Mon Sep 17 00:00:00 2001
-From: Ryan Farley <ryan.farley@gmx.com>
-Date: Sun, 26 Apr 2020 09:52:54 -0500
-Subject: [PATCH] add needed qiodevice include
-
----
- gui/include/device.h | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/gui/include/device.h b/gui/include/device.h
-index 85cc9d2..1ca5ece 100644
---- a/gui/include/device.h
-+++ b/gui/include/device.h
-@@ -17,6 +17,7 @@
- #include <QStringList>
- #include <QList>
- #include <QMutex>
-+#include <QIODevice>
-
- #include <sys/time.h>
- #include <inttypes.h>
---
-2.25.0.232.gd8437c57fa
-
diff --git a/PKGBUILD b/PKGBUILD
index 850325c8576f..4aa836a94136 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,23 +4,17 @@
# Contributor: Krzysztof Stasiorowski <krzysiekst@gmail.com>
pkgname=qpxtool
-pkgver=0.8.0
+pkgver=0.8.1
pkgrel=1
pkgdesc="Allows better controll over optical drives to include QChecks and optimization settings."
arch=('x86_64')
url="http://qpxtool.sourceforge.net/"
license=('GPL')
depends=('qt5-base')
-source=(http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2
- 0001-add-needed-qiodevice-include.patch)
-md5sums=('f4b09f8d5aa533f680c8bcce19c1072e'
- 'e494a876eea1078e822d850c8f477487')
+source=(http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2)
+md5sums=('33f210de24ef8dd7c7adac6b41ac8328')
-prepare() {
- cd "$srcdir/$pkgname-$pkgver"
- patch --forward --strip=1 --input "${srcdir}/0001-add-needed-qiodevice-include.patch"
-}
build() {
cd "$srcdir"/$pkgname-$pkgver
# Fix strict aliasing warnings