summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBirk Birkner2023-06-22 18:44:17 +0200
committerBirk Birkner2023-06-22 18:44:17 +0200
commit4d7b91d90f88a5c29f429fbbb64d6c04538c0596 (patch)
tree1a26bb3e2232b3032db2c4e3621fea9b18f4c1e2
downloadaur-4d7b91d90f88a5c29f429fbbb64d6c04538c0596.tar.gz
Initial commit
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD45
2 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bcb97c32f32f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = qrca-git
+ pkgdesc = Scan QR-Codes with your camera on phones and laptops, and create your own for easily sharing data between devices.
+ pkgver = 0.1.r242.370414c
+ pkgrel = 1
+ url = https://apps.kde.org/de/qrca/
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ makedepends = extra-cmake-modules
+ makedepends = qt5-svg
+ makedepends = qt5-quickcontrols2
+ makedepends = qt5-multimedia
+ makedepends = kirigami2
+ makedepends = purpose
+ depends = qt5-declarative
+ depends = hicolor-icon-theme
+ depends = gcc-libs
+ depends = xdg-utils
+ depends = prison
+ depends = kcontacts
+ depends = knotifications
+ depends = kcoreaddons
+ depends = ki18n
+ depends = kio
+ depends = kservice
+ depends = qt5-base
+ provides = qrca
+ conflicts = qrca
+ source = qrca-git::git+https://invent.kde.org/utilities/qrca.git
+ md5sums = SKIP
+
+pkgname = qrca-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d13e1502ba3a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Birk Birkner <aur at bbirkner.de>
+
+pkgname=qrca-git
+pkgver=0.1.r242.370414c
+pkgrel=1
+pkgdesc="Scan QR-Codes with your camera on phones and laptops, and create your own for easily sharing data between devices."
+arch=('x86_64')
+url="https://apps.kde.org/de/qrca/"
+license=('GPL3')
+depends=(
+ 'qt5-declarative'
+ 'hicolor-icon-theme'
+ 'gcc-libs'
+ 'xdg-utils'
+ 'prison'
+ 'kcontacts'
+ 'knotifications'
+ 'kcoreaddons'
+ 'ki18n'
+ 'kio'
+ 'kservice'
+ 'qt5-base'
+)
+makedepends=(git cmake extra-cmake-modules qt5-svg qt5-quickcontrols2 qt5-multimedia kirigami2 purpose)
+provides=('qrca')
+conflicts=('qrca')
+source=($pkgname::"git+https://invent.kde.org/utilities/qrca.git")
+md5sums=('SKIP')
+
+pkgver () {
+ cd "$srcdir/$pkgname"
+ printf "%s.r%s.%s" "$(awk '{if ($1 ~ "qrca") {print substr($3, 1, length($3)-1)}}' CMakeLists.txt)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build () {
+ cmake -B build -S "$pkgname" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -Wno-dev
+ cmake --build build
+}
+
+package () {
+ DESTDIR="$pkgdir" cmake --install build
+}