summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilipe Nascimento2020-05-17 21:10:19 -0300
committerFilipe Nascimento2020-05-17 21:10:19 -0300
commitc4ad64c82ec2b3de80894afb129de0946f83069e (patch)
treea5a78510a18f48eebda11e39e54a4c5c792f37e9
parent49310249974f266aae825f03401c0b977211048e (diff)
downloadaur-c4ad64c82ec2b3de80894afb129de0946f83069e.tar.gz
upgpkg: qrcp 0.6.3-1
upstream release
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f8fb284512d5..ff15ecc92f27 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qrcp
pkgdesc = Transfer files over Wi-Fi from your computer to a mobile device by scanning a QR code without leaving the terminal
- pkgver = 0.6.2
+ pkgver = 0.6.3
pkgrel = 1
url = https://github.com/claudiodangelis/qrcp
arch = i686
@@ -8,10 +8,10 @@ pkgbase = qrcp
arch = armv7h
arch = aarch64
license = MIT
- makedepends = go-pie
+ makedepends = go
depends = glibc
- source = qrcp-0.6.2.tar.gz::https://github.com/claudiodangelis/qrcp/archive/0.6.2.tar.gz
- sha256sums = a71105cbe0e6cfee4772b72a531c9532c6f9550d22614a7f09ee4902ed813820
+ source = qrcp-0.6.3.tar.gz::https://github.com/claudiodangelis/qrcp/archive/0.6.3.tar.gz
+ sha256sums = 2d39ba661aad9c60b816bc06f53ef4f3d8747e11d5fc27c104d3687d1e77204c
pkgname = qrcp
diff --git a/PKGBUILD b/PKGBUILD
index 6f75479c65dd..17ffa538a911 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,26 @@
# Maintainer: Filipe Nascimento <flipee at tuta dot io>
pkgname=qrcp
-pkgver=0.6.2
+pkgver=0.6.3
pkgrel=1
pkgdesc="Transfer files over Wi-Fi from your computer to a mobile device by scanning a QR code without leaving the terminal"
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
url="https://github.com/claudiodangelis/qrcp"
license=('MIT')
depends=('glibc')
-makedepends=('go-pie')
+makedepends=('go')
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('a71105cbe0e6cfee4772b72a531c9532c6f9550d22614a7f09ee4902ed813820')
+sha256sums=('2d39ba661aad9c60b816bc06f53ef4f3d8747e11d5fc27c104d3687d1e77204c')
build() {
cd $pkgname-$pkgver
- go build -trimpath -ldflags "-extldflags $LDFLAGS" -o $pkgname
+ go build \
+ -trimpath \
+ -buildmode=pie \
+ -mod=readonly \
+ -modcacherw \
+ -ldflags "-extldflags $LDFLAGS" \
+ -o $pkgname
}
package() {