summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThiago Almeida2023-04-13 20:41:41 +0200
committerThiago Almeida2023-04-13 20:41:41 +0200
commit7eabf7a668809fe70637ee4c7d187d68bd6d9175 (patch)
tree73db2249707a15d6a65e481e66bbef3c266067a6
parent2de57e7f995e8c42fb0a4cc83c8ed5fdc9074fe9 (diff)
downloadaur-7eabf7a668809fe70637ee4c7d187d68bd6d9175.tar.gz
feat(arch): added extra arch
* added: * armv7h * aarch64
-rw-r--r--[-rwxr-xr-x].SRCINFO13
-rw-r--r--[-rwxr-xr-x]PKGBUILD22
2 files changed, 21 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d42018a532d8..119f6625e274 100755..100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,21 @@
pkgbase = qrcp-bin
pkgdesc = Transfer files over wifi from your computer to your mobile device by scanning a QR code without leaving the terminal.
pkgver = 0.10.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/claudiodangelis/qrcp
arch = x86_64
arch = i386
+ arch = armv7h
+ arch = aarch64
license = MIT
provides = qrcp
- conflicts = qrcp-git
- conflicts = qr-filetransfer-git
conflicts = qrcp
+ conflicts = qrcp-git
source_x86_64 = qrcp-bin-0.10.1.tar.gz::https://github.com/claudiodangelis/qrcp/releases/download/0.10.1/qrcp_0.10.1_linux_x86_64.tar.gz
- sha256sums_x86_64 = d9f1bdf1c9ae80dd7e731556be75341cf76e3462b6ae8405ca4f608c5370fd16
+ sha256sums_x86_64 = 27b1f2b9004ecf967a4abe95bd324b99b4f077f0c627ad96ea16e18644dce26e
source_i386 = qrcp-bin-0.10.1.tar.gz::https://github.com/claudiodangelis/qrcp/releases/download/0.10.1/qrcp_0.10.1_linux_i386.tar.gz
- sha256sums_i386 = ce95248a65548ab15f12acba7cd642c83efeb261bb28a92d6d913fa6ed48bb3a
+ sha256sums_i386 = 27b1f2b9004ecf967a4abe95bd324b99b4f077f0c627ad96ea16e18644dce26e
+ source_aarch64 = qrcp-bin-0.10.1.tar.gz::https://github.com/claudiodangelis/qrcp/releases/download/0.10.1/qrcp_0.10.1_linux_arm64.tar.gz
+ sha256sums_aarch64 = 27b1f2b9004ecf967a4abe95bd324b99b4f077f0c627ad96ea16e18644dce26e
pkgname = qrcp-bin
diff --git a/PKGBUILD b/PKGBUILD
index b7bdcf8e9a83..3a19a10236e8 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,23 @@
# Maintainer: Thiago Almeida <echo "dGhpYWdvYWxtZWlkYXNhQGdtYWlsLmNvbQo=" | base64 -d>
-pkgname="qrcp-bin"
+pkgname=qrcp-bin
pkgver=0.10.1
-pkgrel=2
+pkgrel=3
+provides=("${pkgname/-bin/}")
+conflicts=('qrcp' 'qrcp-git')
pkgdesc="Transfer files over wifi from your computer to your mobile device by scanning a QR code without leaving the terminal."
+arch=('x86_64' 'i386' 'armv7h' 'aarch64')
url="https://github.com/claudiodangelis/qrcp"
-arch=('x86_64' 'i386')
license=('MIT')
-provides=('qrcp')
-conflicts=('qrcp-git' 'qr-filetransfer-git' 'qrcp')
source_x86_64=("$pkgname-$pkgver.tar.gz::$url/releases/download/${pkgver}/${pkgname/-bin/}_${pkgver}_linux_x86_64.tar.gz")
source_i386=("$pkgname-$pkgver.tar.gz::$url/releases/download/${pkgver}/${pkgname/-bin/}_${pkgver}_linux_i386.tar.gz")
-sha256sums_x86_64=(d9f1bdf1c9ae80dd7e731556be75341cf76e3462b6ae8405ca4f608c5370fd16)
-sha256sums_i386=(ce95248a65548ab15f12acba7cd642c83efeb261bb28a92d6d913fa6ed48bb3a)
+source_aarch64=("$pkgname-$pkgver.tar.gz::$url/releases/download/${pkgver}/${pkgname/-bin/}_${pkgver}_linux_arm64.tar.gz")
+source_armv7h=("$pkgname-$pkgver.tar.gz::$url/releases/download/${pkgver}/${pkgname/-bin/}_${pkgver}_linux_armv7h.tar.gz")
+sha256sums_x86_64=('27b1f2b9004ecf967a4abe95bd324b99b4f077f0c627ad96ea16e18644dce26e')
+sha256sums_i386=('27b1f2b9004ecf967a4abe95bd324b99b4f077f0c627ad96ea16e18644dce26e')
+sha256sums_aarch64=('27b1f2b9004ecf967a4abe95bd324b99b4f077f0c627ad96ea16e18644dce26e')
+sha256sums_armv7h=('27b1f2b9004ecf967a4abe95bd324b99b4f077f0c627ad96ea16e18644dce26e')
build() {
./qrcp completion bash | install -Dm644 /dev/stdin share/bash-completion/completions/qrcp
@@ -24,6 +28,6 @@ build() {
package() {
install -Dm755 qrcp "$pkgdir/usr/bin/qrcp"
cp -r share/ "$pkgdir/usr"
- install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
- install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/${pkgname/-bin/}"
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/${pkgname/-bin/}"
}