summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiguel Angel Useche Castro2020-06-08 11:10:34 -0500
committerMiguel Angel Useche Castro2020-06-08 11:10:34 -0500
commitb7cfc29d5fdbaf80637c1d0923fa9128c9d3e6d6 (patch)
tree52c7ba7910e98ef95f6dd0b29814ea236eb3f5c3
downloadaur-b7cfc29d5fdbaf80637c1d0923fa9128c9d3e6d6.tar.gz
initial version
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9ad11f4cf396
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = qrcp-git
+ pkgdesc = Transfer files over wifi from your computer to your mobile device by scanning a QR code without leaving the terminal.
+ pkgver = r173.c6b4c74
+ pkgrel = 1
+ url = https://github.com/claudiodangelis/qrcp
+ arch = any
+ license = MIT
+ makedepends = go>=1.8
+ makedepends = git
+ provides = qrcp
+ options = !strip
+ options = !emptydirs
+ source = git://github.com/claudiodangelis/qrcp
+ sha512sums = SKIP
+
+pkgname = qrcp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5297a00a7371
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Miguel Useche <migueluseche@skatox.com>
+
+_pkgname=qrcp
+_gourl="github.com/claudiodangelis/$_pkgname"
+pkgname="$_pkgname-git"
+pkgver=r173.c6b4c74
+pkgrel=1
+pkgdesc="Transfer files over wifi from your computer to your mobile device by scanning a QR code without leaving the terminal."
+arch=('any')
+url="https://$_gourl"
+license=('MIT')
+makedepends=('go>=1.8' 'git')
+provides=("$_pkgname")
+options=('!strip' '!emptydirs')
+source=("git://$_gourl")
+sha512sums=('SKIP')
+
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ GOPATH="$srcdir" go get -fix -v -x "$_gourl"
+}
+
+package() {
+ install -Dpm755 "$srcdir/bin/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+ install -Dm644 "$srcdir/src/$_gourl/LICENSE" "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+}