summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincenzo Maffione2015-11-13 12:08:51 +0100
committerVincenzo Maffione2015-11-13 12:08:51 +0100
commit22381ebb91fe9608247ba9e0d951678a71b51aab (patch)
tree382715fb7a8db50c085c9217e59114cb09bc9009
downloadaur-22381ebb91fe9608247ba9e0d951678a71b51aab.tar.gz
Import PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..724872707cb6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = qrun-git
+ pkgdesc = A command line tool to run QEMU in the most common configurations
+ pkgver = r12.2be08ea
+ pkgrel = 1
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = python
+ depends = qemu
+ depends = bridge-utils
+ depends = iproute2
+ source = git+https://github.com/vmaffione/qrun
+ md5sums = SKIP
+
+pkgname = qrun-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..82a7af666714
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# See http://wiki.archlinux.org/index.php/VCS_PKGBUILD_Guidelines
+# for more information on packaging from GIT sources.
+
+# Maintainer: Vincenzo Maffione <v.maffione@gmail.com>
+pkgname=qrun-git
+pkgver=r12.2be08ea
+pkgrel=1
+pkgdesc="A command line tool to run QEMU in the most common configurations"
+arch=('any')
+license=('GPL')
+depends=('python' 'qemu' 'bridge-utils' 'iproute2')
+makedepends=('git')
+source=('git+https://github.com/vmaffione/qrun')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ # Install the script into /usr/bin
+ mkdir -p "$pkgdir/usr/bin"
+ install "$srcdir/${pkgname%-git}/qrun.py" "$pkgdir/usr/bin/qrun"
+}
+
+# vim:set ts=2 sw=2 et: