summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephan Springer2018-09-23 18:53:40 +0200
committerStephan Springer2018-09-23 18:53:40 +0200
commit70ae5797687984399aa8d11f322765f708692fb9 (patch)
tree85de5448e72477f63074a12e8c52add99f7681af
downloadaur-70ae5797687984399aa8d11f322765f708692fb9.tar.gz
version 2.10.7 – adopted from extra/qscintilla
-rw-r--r--.SRCINFO43
-rw-r--r--PKGBUILD98
2 files changed, 141 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a8bead661da2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,43 @@
+pkgbase = qscintilla-qt4
+ pkgver = 2.10.7
+ pkgrel = 4
+ url = http://www.riverbankcomputing.co.uk/software/qscintilla/intro
+ arch = x86_64
+ license = GPL
+ makedepends = qt4
+ makedepends = python-pyqt4
+ makedepends = python2-pyqt4
+ options = !buildflags
+ source = http://downloads.sourceforge.net/pyqt/QScintilla_gpl-2.10.7.tar.gz
+ sha256sums = 670458de71dd4205e92d8f3b7bad9f667afece925703cde9df6d04bc23331a1a
+
+pkgname = qscintilla-qt4
+ pkgdesc = A port to Qt4 of Neil Hodgson's Scintilla C++ editor class
+ depends = qt4
+ provides = qscintilla=2.10.7
+ conflicts = qscintilla<2.9.1
+ replaces = qscintilla<2.9.1
+
+pkgname = python-qscintilla-qt4
+ pkgdesc = Python 3.x bindings for QScintilla2
+ depends = python-qscintilla-qt4-common
+ depends = python-pyqt4
+ provides = python-qscintilla=2.10.7
+ conflicts = python-qscintilla<2.9.1
+ replaces = python-qscintilla<2.9.1
+
+pkgname = python2-qscintilla-qt4
+ pkgdesc = Python 2.x bindings for QScintilla2
+ depends = python-qscintilla-qt4-common
+ depends = python2-pyqt4
+ provides = python2-qscintilla=2.10.7
+ conflicts = python2-qscintilla<2.9.1
+ replaces = python2-qscintilla<2.9.1
+
+pkgname = python-qscintilla-qt4-common
+ pkgdesc = Common python qscintilla bindings files shared between python-qscintilla-qt4 and python2-qscintilla-qt4
+ depends = qscintilla-qt4
+ provides = python-qscintilla-common=2.10.7
+ conflicts = python-qscintilla-common<2.9.1
+ replaces = python-qscintilla-common<2.9.1
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..290a3bc7c6a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,98 @@
+# Maintainer: Stephan Springer <buzo+arch@Lini.de>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Douglas Soares de Andrade <dsa@aur.archlinux.org>
+
+pkgbase=qscintilla-qt4
+pkgname=('qscintilla-qt4' 'python-qscintilla-qt4' 'python2-qscintilla-qt4'
+ 'python-qscintilla-qt4-common')
+pkgver=2.10.7
+pkgrel=4
+license=('GPL')
+arch=('x86_64')
+url="http://www.riverbankcomputing.co.uk/software/qscintilla/intro"
+makedepends=('qt4' 'python-pyqt4' 'python2-pyqt4')
+options=('!buildflags') # Fix Qt Designer plugin
+source=("http://downloads.sourceforge.net/pyqt/QScintilla_gpl-${pkgver}.tar.gz")
+sha256sums=('670458de71dd4205e92d8f3b7bad9f667afece925703cde9df6d04bc23331a1a')
+
+prepare() {
+ cp -a QScintilla_gpl-${pkgver}{,-qt4}
+}
+
+build() {
+ export QMAKEFEATURES=$PWD/Qt4Qt5/features/
+ cd "$srcdir"/QScintilla_gpl-${pkgver}-qt4/Qt4Qt5
+ qmake-qt4
+ make
+
+ cd ../designer-Qt4Qt5
+ qmake-qt4 INCLUDEPATH+=../Qt4Qt5 QMAKE_LIBDIR+=../Qt4Qt5
+ make
+
+ cd ..
+ cp -rf Python Python2
+ cd Python
+ python configure.py -n ../Qt4Qt5/ -o ../Qt4Qt5/ -c --qmake /usr/bin/qmake-qt4 --no-dist-info
+ make
+
+ cd ../Python2
+ python2 configure.py -n ../Qt4Qt5/ -o ../Qt4Qt5/ -c --qmake /usr/bin/qmake-qt4 --no-dist-info
+ make
+}
+
+package_qscintilla-qt4() {
+ pkgdesc="A port to Qt4 of Neil Hodgson's Scintilla C++ editor class"
+ depends=('qt4')
+ replaces=('qscintilla<2.9.1')
+ conflicts=('qscintilla<2.9.1')
+ provides=("qscintilla=$pkgver")
+
+ cd QScintilla_gpl-${pkgver}-qt4/Qt4Qt5
+ make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
+
+ cd ../designer-Qt4Qt5
+ make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
+}
+
+package_python-qscintilla-qt4-common() {
+ pkgdesc="Common python qscintilla bindings files shared between python-qscintilla-qt4 and python2-qscintilla-qt4"
+ depends=('qscintilla-qt4')
+ replaces=('python-qscintilla-common<2.9.1')
+ conflicts=('python-qscintilla-common<2.9.1')
+ provides=("python-qscintilla-common=$pkgver")
+
+ cd QScintilla_gpl-${pkgver}-qt4/Python
+ make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
+
+ # Provided by python-qscintilla
+ rm -r "${pkgdir}"/usr/lib
+}
+
+package_python-qscintilla-qt4() {
+ pkgdesc="Python 3.x bindings for QScintilla2"
+ depends=('python-qscintilla-qt4-common' 'python-pyqt4')
+ replaces=('python-qscintilla<2.9.1')
+ conflicts=('python-qscintilla<2.9.1')
+ provides=("python-qscintilla=$pkgver")
+
+ cd QScintilla_gpl-${pkgver}-qt4/Python
+ make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
+
+ # Provided by python2-qscintilla-common
+ rm -r "${pkgdir}"/usr/share
+}
+
+package_python2-qscintilla-qt4() {
+ pkgdesc="Python 2.x bindings for QScintilla2"
+ depends=('python-qscintilla-qt4-common' 'python2-pyqt4')
+ replaces=('python2-qscintilla<2.9.1')
+ conflicts=('python2-qscintilla<2.9.1')
+ provides=("python2-qscintilla=$pkgver")
+
+ cd QScintilla_gpl-${pkgver}-qt4/Python2
+ make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
+
+ # Provided by python2-qscintilla-common
+ rm -r "${pkgdir}"/usr/share
+}