summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoragafron2019-10-30 00:18:32 +0200
committeragafron2019-10-30 00:18:32 +0200
commit7a8c0ca558b5b6873372c5252b712df401f76d52 (patch)
tree6aed139e1c4e802b24bed2613e12026bb27d123a
downloadaur-7a8c0ca558b5b6873372c5252b712df401f76d52.tar.gz
first commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD24
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..870f31fc155e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = qshutdown
+ pkgdesc = Shutdown your computer
+ pkgver = 1.7.3.0
+ pkgrel = 1
+ url = https://launchpad.net/~hakaishi/+archive/ubuntu/qshutdown
+ arch = x86_64
+ license = custom
+ depends = qt5-tools
+ depends = qt5-quick1
+ depends = qt5-websockets
+ depends = qt5-svg
+ depends = gstreamer0.10-base
+ depends = libxss
+ depends = qt5-imageformats
+ source = http://ppa.launchpad.net/hakaishi/qshutdown/ubuntu/pool/main/q/qshutdown/qshutdown_1.7.3.0.orig.tar.gz
+ md5sums = 3789710c36e3979b3dd90f8fd943018e
+
+pkgname = qshutdown
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec4486c75fa9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: hakaishi
+
+pkgname=qshutdown
+pkgver=1.7.3.0
+pkgrel=1
+pkgdesc="Shutdown your computer"
+arch=('x86_64')
+url="https://launchpad.net/~hakaishi/+archive/ubuntu/qshutdown"
+license=('custom')
+depends=('qt5-tools' 'qt5-quick1' 'qt5-websockets' 'qt5-svg' 'gstreamer0.10-base' 'libxss' 'qt5-imageformats')
+source=("http://ppa.launchpad.net/hakaishi/qshutdown/ubuntu/pool/main/q/qshutdown/${pkgname}_${pkgver}.orig.tar.gz")
+md5sums=('3789710c36e3979b3dd90f8fd943018e')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ qmake
+ make -j4
+ }
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make INSTALL_ROOT="$pkgdir" install
+ }