summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent2017-06-04 01:33:05 +0200
committerVincent2017-06-04 01:33:05 +0200
commit8dafc39d36b37d276b61503d5da50cd708a196aa (patch)
tree96d0dc8b176fc2e6a163fcf561bc7f5ae6135c03
parentd6314bd5f44b4b12ccbc1e8ab3b0c6d2e9a1650c (diff)
downloadaur-8dafc39d36b37d276b61503d5da50cd708a196aa.tar.gz
fixing compilation of qsiapitest.cpp
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
-rw-r--r--qsiapitest_init.patch13
3 files changed, 18 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d40ac7fc01f..5391ae92512b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,7 +10,9 @@ pkgbase = qsiapi
depends = bash
depends = libftdi
source = http://qsimaging.com/downloads/qsiapi-7.6.0.tar.gz
+ source = qsiapitest_init.patch
sha1sums = c2d91e91c48e0e3f81938da8f29c5319f02e6bd4
+ sha1sums = 5c773b50baf7d6789be9a0d11c42fc888723f629
pkgname = qsiapi
diff --git a/PKGBUILD b/PKGBUILD
index 5bb71794598d..cd9e3b6c7ecc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,12 +7,13 @@ url="http://www.qsimaging.com/software-beta.html#api"
arch=('i686' 'x86_64')
license=('custom')
depends=('bash' 'libftdi')
-source=("http://qsimaging.com/downloads/${pkgname}-${pkgver}.tar.gz")
-sha1sums=('c2d91e91c48e0e3f81938da8f29c5319f02e6bd4')
+source=("http://qsimaging.com/downloads/${pkgname}-${pkgver}.tar.gz" "qsiapitest_init.patch")
+sha1sums=('c2d91e91c48e0e3f81938da8f29c5319f02e6bd4' '5c773b50baf7d6789be9a0d11c42fc888723f629')
install="${pkgname}.install"
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -p0 < ../qsiapitest_init.patch
autoreconf -fi
./configure --with-ftd=ftdi1 --prefix=/usr --enable-shared
make all
diff --git a/qsiapitest_init.patch b/qsiapitest_init.patch
new file mode 100644
index 000000000000..d159c43af986
--- /dev/null
+++ b/qsiapitest_init.patch
@@ -0,0 +1,13 @@
+--- src/qsiapitest.cpp.orig 2017-03-31 00:23:56.000000000 +0200
++++ src/qsiapitest.cpp 2017-06-04 01:31:07.142438223 +0200
+@@ -193,8 +193,8 @@
+ std::cout << "qsiapitest version: " << info << "\n";
+ //Discover the connected cameras
+ int iNumFound;
+- std::string camSerial[QSICamera::MAXCAMERAS] = "";
+- std::string camDesc[QSICamera::MAXCAMERAS] = "";
++ std::string camSerial[QSICamera::MAXCAMERAS] = {};
++ std::string camDesc[QSICamera::MAXCAMERAS] = {};
+
+ cam.get_AvailableCameras(camSerial, camDesc, iNumFound);
+