summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent2015-07-06 01:26:34 +0200
committerVincent2015-07-06 01:26:34 +0200
commitba5450aa57b9b19083bfa66f4632ba6d06a295a0 (patch)
tree0924af5e0b856f8d0ea44dd330702c73115ac8d1
downloadaur-ba5450aa57b9b19083bfa66f4632ba6d06a295a0.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
-rw-r--r--qsiapi.install35
3 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..130f2c6951a8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = qsiapi
+ pkgdesc = C++ API for QSI camera control and image capture via the USB interface
+ pkgver = 7.2.0
+ pkgrel = 1
+ url = http://www.qsimaging.com/software-beta.html#api
+ install = qsiapi.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = bash
+ depends = libftdi
+ source = http://qsimaging.com/downloads/qsiapi-7.2.0.tar.gz
+ sha1sums = 3c11fcefb122856807db6da937cb7fac4b0887fd
+
+pkgname = qsiapi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f7ac5b5a683e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Vincent Hourdin <aur at vinvin dot tf>
+pkgname=qsiapi
+pkgver=7.2.0
+pkgrel=1
+pkgdesc="C++ API for QSI camera control and image capture via the USB interface"
+url="http://www.qsimaging.com/software-beta.html#api"
+arch=('i686' 'x86_64')
+license=('custom')
+depends=('bash' 'libftdi')
+# makedepends=('gcc46')
+source=("http://qsimaging.com/downloads/${pkgname}-${pkgver}.tar.gz")
+sha1sums=('3c11fcefb122856807db6da937cb7fac4b0887fd')
+install="${pkgname}.install"
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --enable-libftdi --prefix=/usr --enable-shared
+ make all
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ rm "${pkgdir}/usr/lib/libqsiapi.la" #it's a libtool file
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+}
+
diff --git a/qsiapi.install b/qsiapi.install
new file mode 100644
index 000000000000..e4b5c129f5f9
--- /dev/null
+++ b/qsiapi.install
@@ -0,0 +1,35 @@
+# arg 1: the new package version
+post_install() {
+ display_help
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ display_help
+}
+
+display_help() {
+ cat << EOF
+
+Ensure that the device permissions are correct. Update udev or add the following
+line to /etc/fstab (if it does not already exist):
+
+ none /proc/bus/usb usbfs defaults,devmode=0666 0 0
+
+TO TEST THAT THE CAMERA IS WORKING:
+1. Connect the QSI camera to AC power and connect the USB cable from the camera to
+an available USB port on the computer. Use usbview or lsusb to verify proper USB
+installation.
+
+2. Confirm that all libraries are loaded and the system is properly configured.
+
+3. Run qsiapitest.
+
+qsiapitest first displays the version of the api. If there is a QSI camera
+connected to the system, it will execute a series of command to exercise the
+camera. See the qsiapitest.cpp source code for further details.
+EOF
+ # TODO: cat the licence too?
+}
+