summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent2017-04-25 23:56:11 +0200
committerVincent2017-04-25 23:56:11 +0200
commitd6314bd5f44b4b12ccbc1e8ab3b0c6d2e9a1650c (patch)
tree75e77f3ec4be75617ed82d8cf8e2c7c2c12ed7b8
parent916eb28490d3bf1d9df4084563b0b0c4117d3ff8 (diff)
downloadaur-d6314bd5f44b4b12ccbc1e8ab3b0c6d2e9a1650c.tar.gz
update to 7.6.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
-rw-r--r--patch_libftdi1.diff13
3 files changed, 7 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15a11e5a311b..0d40ac7fc01f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qsiapi
pkgdesc = C++ API for QSI camera control and image capture via the USB interface
- pkgver = 7.2.0
+ pkgver = 7.6.0
pkgrel = 1
url = http://www.qsimaging.com/software-beta.html#api
install = qsiapi.install
@@ -9,10 +9,8 @@ pkgbase = qsiapi
license = custom
depends = bash
depends = libftdi
- source = http://qsimaging.com/downloads/qsiapi-7.2.0.tar.gz
- source = patch_libftdi1.diff
- sha1sums = 3c11fcefb122856807db6da937cb7fac4b0887fd
- sha1sums = e8076f6501d13ee64fdf6fd3d421444b78bec125
+ source = http://qsimaging.com/downloads/qsiapi-7.6.0.tar.gz
+ sha1sums = c2d91e91c48e0e3f81938da8f29c5319f02e6bd4
pkgname = qsiapi
diff --git a/PKGBUILD b/PKGBUILD
index 1f29d7dc0258..5bb71794598d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,20 @@
# Maintainer: Vincent Hourdin <aur at vinvin dot tf>
pkgname=qsiapi
-pkgver=7.2.0
+pkgver=7.6.0
pkgrel=1
pkgdesc="C++ API for QSI camera control and image capture via the USB interface"
url="http://www.qsimaging.com/software-beta.html#api"
arch=('i686' 'x86_64')
license=('custom')
depends=('bash' 'libftdi')
-# makedepends=('gcc46')
-source=("http://qsimaging.com/downloads/${pkgname}-${pkgver}.tar.gz" "patch_libftdi1.diff")
-sha1sums=('3c11fcefb122856807db6da937cb7fac4b0887fd' 'e8076f6501d13ee64fdf6fd3d421444b78bec125')
+source=("http://qsimaging.com/downloads/${pkgname}-${pkgver}.tar.gz")
+sha1sums=('c2d91e91c48e0e3f81938da8f29c5319f02e6bd4')
install="${pkgname}.install"
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- patch < patch_libftdi1.diff
autoreconf -fi
- ./configure --enable-libftdi --prefix=/usr --enable-shared
+ ./configure --with-ftd=ftdi1 --prefix=/usr --enable-shared
make all
}
diff --git a/patch_libftdi1.diff b/patch_libftdi1.diff
deleted file mode 100644
index 92510f353dda..000000000000
--- a/patch_libftdi1.diff
+++ /dev/null
@@ -1,13 +0,0 @@
---- configure.ac.orig 2013-12-03 19:18:06.000000000 +0100
-+++ configure.ac 2016-10-22 17:47:30.615768853 +0200
-@@ -75,8 +75,8 @@
- fi
-
- if test x$enable_ftdi = xyes; then
-- FTDI_CFLAGS="-I/usr/local/include"
-- FTDI_LIBS="-L/usr/local/lib -lftdi"
-+ FTDI_CFLAGS="-I/usr/include/libftdi1"
-+ FTDI_LIBS="-lftdi1"
- AC_SUBST(FTDI_CFLAGS)
- AC_SUBST(FTDI_LIBS)
- fi