summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJens Staal2020-09-15 17:27:00 +0200
committerJens Staal2020-09-15 17:27:00 +0200
commit525966aa6f6850b6ee39624fb6336907fd7c3547 (patch)
treee5d6a5e4b7edad2a690a33bdd1879f0c1c984cc5
downloadaur-525966aa6f6850b6ee39624fb6336907fd7c3547.tar.gz
first commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD37
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..971e59c445f7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = qspec-git
+ pkgdesc = A GUI testing library for Qt desktop applications
+ pkgver = v0.2.r115.gaaae422
+ pkgrel = 1
+ url = http://ugene.unipro.ru/
+ arch = x86_64
+ license = GPL
+ depends = qt5-base
+ depends = libxtst
+ source = qspec::git+https://github.com/ugeneunipro/QSpec.git
+ sha256sums = SKIP
+
+pkgname = qspec-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c667937ebc82
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Jens Staal <staal1978@gmail.com>
+pkgname=qspec-git
+pkgver=v0.2.r115.gaaae422
+pkgrel=1
+pkgdesc="A GUI testing library for Qt desktop applications"
+arch=('x86_64')
+url="http://ugene.unipro.ru/"
+license=('GPL')
+depends=('qt5-base' 'libxtst')
+source=('qspec::git+https://github.com/ugeneunipro/QSpec.git')
+sha256sums=('SKIP')
+
+build() {
+ cd "${srcdir}"/qspec
+ #make sure that the wanted branch is active
+ git checkout master
+ qmake CONFIG+=x64 PREFIX=/usr -r
+ make
+}
+
+pkgver() {
+ cd "${srcdir}"/qspec
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/; s/-/./g'
+}
+
+package() {
+ cd "${srcdir}"/qspec
+ make INSTALL_ROOT="$pkgdir" install
+}
+
+post_install() {
+ update-desktop-database -q
+}
+post_remove() {
+ update-desktop-database -q
+}
+