summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSkycoder422017-06-13 16:58:29 +0200
committerSkycoder422017-06-13 16:58:29 +0200
commita618a02ce3c7b5a41e6db30dc6ee428547f6b5a2 (patch)
tree30a960e14c001337dc0550eb2f19ab6e4b6a294d
parent43cddde95db59ec73e266c4345a72fad9923b61c (diff)
downloadaur-a618a02ce3c7b5a41e6db30dc6ee428547f6b5a2.tar.gz
Updated to 1.1.0
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b424b743d4..401f5e09e52 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = qsshfs
pkgdesc = A gui wrapper around sshfs, written in Qt
- pkgver = 1.0.1
+ pkgver = 1.1.0
pkgrel = 1
url = https://github.com/Skycoder42/qsshfs
arch = i686
arch = x86_64
license = BSD
makedepends = git
+ makedepends = qpm
depends = qt5-base
depends = qt5-tools
depends = sshfs
- optdepends = ksshaskpass: SSH_ASKPASS is required. This is one possible implementation for it.
- source = qsshfs-1.0.1::git+https://github.com/Skycoder42/qsshfs.git#tag=1.0.1
+ optdepends = x11-ssh-askpass: SSH_ASKPASS is required. This is one possible implementation for it.
+ source = qsshfs-1.1.0::git+https://github.com/Skycoder42/qsshfs.git#tag=1.1.0
md5sums = SKIP
pkgname = qsshfs
diff --git a/PKGBUILD b/PKGBUILD
index 8ca5de5fcd8..cfd4dcbe022 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,20 @@
# Maintainer: Felix Barz <skycoder42.de@gmx.de>
pkgname=qsshfs
-pkgver=1.0.1
+pkgver=1.1.0
pkgrel=1
pkgdesc="A gui wrapper around sshfs, written in Qt"
arch=('i686' 'x86_64')
url="https://github.com/Skycoder42/qsshfs"
license=('BSD')
depends=('qt5-base' 'qt5-tools' 'sshfs')
-makedepends=('git')
-optdepends=("ksshaskpass: SSH_ASKPASS is required. This is one possible implementation for it.")
+makedepends=('git' 'qpm')
+optdepends=("x11-ssh-askpass: SSH_ASKPASS is required. This is one possible implementation for it.")
source=("$pkgname-$pkgver::git+https://github.com/Skycoder42/qsshfs.git#tag=$pkgver")
md5sums=('SKIP')
build() {
cd "$pkgname-$pkgver"
- git config submodule.QPathEdit.url "https://github.com/Skycoder42/QPathEdit.git"
- git config submodule.QtUtils.url "https://github.com/Skycoder42/QtUtils.git"
- git submodule update --init --recursive
+ qpm install
qmake
make qmake_all
@@ -27,6 +25,8 @@ package() {
cd "$pkgname-$pkgver"
make INSTALL_ROOT="$pkgdir" install
+
+ install -D -m644 de.skycoder42.${pkgname}.desktop "$pkgdir/usr/share/applications/de.skycoder42.${pkgname}.desktop"
install -D -m644 ${pkgname}_32.png "$pkgdir/usr/share/icons/hicolor/32x32/apps/$pkgname.png"
install -D -m644 ${pkgname}_16.png "$pkgdir/usr/share/icons/hicolor/16x16/apps/$pkgname.png"
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"