summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlashbunny2014-11-23 22:17:40 -0500
committerSlashbunny2014-11-23 22:17:40 -0500
commit9e227ee474b547b7c9a214f55268a5682ffcb892 (patch)
tree507f11aa46c1bbcea46554bf075b8698c27992e8
downloadaur-9e227ee474b547b7c9a214f55268a5682ffcb892.tar.gz
New qstat-git pkgbuild
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD38
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fdadc23d8f0d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = qstat-git
+ pkgdesc = A command line utility that displays the status of internet game servers
+ pkgver = r391.60dc5e4
+ pkgrel = 1
+ url = https://github.com/multiplay/qstat
+ arch = i686
+ arch = x86_64
+ license = Artistic2.0
+ makedepends = subversion
+ depends = glibc
+ provides = qstat
+ conflicts = qstat
+ conflicts = qstat-cvs
+ conflicts = qstat-svn
+ replaces = qstat-cvs
+ replaces = qstat-svn
+ source = qstat::git+https://github.com/multiplay/qstat.git
+ sha256sums = SKIP
+
+pkgname = qstat-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..09171ad12a1a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+qstat/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ba375a71adbf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Slash <demodevil5[at]yahoo[dot]com>
+
+pkgname=qstat-git
+pkgver=r391.60dc5e4
+pkgrel=1
+pkgdesc="A command line utility that displays the status of internet game servers"
+url="https://github.com/multiplay/qstat"
+arch=('i686' 'x86_64')
+license=('Artistic2.0')
+depends=('glibc')
+makedepends=('subversion')
+replaces=('qstat-cvs' 'qstat-svn')
+conflicts=('qstat' 'qstat-cvs' 'qstat-svn')
+provides=('qstat')
+source=('qstat::git+https://github.com/multiplay/qstat.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "qstat"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/qstat"
+
+ sed "s#strndup#strndupz0r#g" -i qstat.c
+
+ ./autogen.sh
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make
+}
+
+package() {
+ cd "${srcdir}/qstat"
+
+ make DESTDIR="${pkgdir}" install
+}