summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlberto Salvia Novella2019-10-29 18:20:44 +0100
committerAlberto Salvia Novella2019-10-29 18:20:44 +0100
commit6ef242a5b736f53c6f9d30aaf609d2960844f6ff (patch)
tree0ed43ca00d8b01437a41853f39a812a3c28978a5
parent4add87ddc6ac6027c0016f362443ad1ada7c2fd2 (diff)
downloadaur-6ef242a5b736f53c6f9d30aaf609d2960844f6ff.tar.gz
2019-10-29 1572369644
-rwxr-xr-xBUILD67
-rwxr-xr-xPUBLISH54
2 files changed, 0 insertions, 121 deletions
diff --git a/BUILD b/BUILD
deleted file mode 100755
index 2487916b2d24..000000000000
--- a/BUILD
+++ /dev/null
@@ -1,67 +0,0 @@
-#! /bin/bash
-# (GPL3+) Alberto Salvia Novella (es20490446e.wordpress.com)
-
-
-mainFunction () {
- updateInfoFile
- buildPackage
-}
-
-
-buildPackage () {
- removeBuildFiles
- makePackage
- removeBuildFiles
-}
-
-
-changeToThisProgramDir () {
- cd "$( dirname "${BASH_SOURCE[0]}" )"
-}
-
-
-makePackage () {
- nice="nice --adjustment=19"
- ionice="ionice -c2 -n7"
-
- silently "makePackage" "PKGEXT='.pkg.tar.gz' ${nice} ${ionice} makepkg --force"
-}
-
-
-removeBuildFiles () {
- name=$(variableInFile "Name" "PKGBUILD")
- folders="pkg src ${name}"
- silently "removeBuildFiles" "rm --recursive --force ${folders}"
-}
-
-
-silently () {
- function="${1}"
- command="${2}"
- error=$(eval "${command}" 2>&1 >"/dev/null")
-
- if [ ${?} -ne 0 ]; then
- echo "${function}: ${error}" >&2
- exit 1
- fi
-}
-
-
-updateInfoFile () {
- silently "updateInfoFile" "makepkg --printsrcinfo > .SRCINFO"
-}
-
-
-variableInFile () {
- variable="${1}"
- file="${2}"
-
- echo $(
- source "${file}";
- eval echo \$\{${variable}\}
- )
-}
-
-
-changeToThisProgramDir
-mainFunction
diff --git a/PUBLISH b/PUBLISH
deleted file mode 100755
index e606dfd7f694..000000000000
--- a/PUBLISH
+++ /dev/null
@@ -1,54 +0,0 @@
-#! /bin/bash
-# (GPL3+) Alberto Salvia Novella (es20490446e.wordpress.com)
-
-
-mainFunction () {
- summary=$(summary "${1}")
-
- updateInfoFile
- publish "${summary}"
-}
-
-
-changeToThisProgramDir () {
- cd "$( dirname "${BASH_SOURCE[0]}" )"
-}
-
-
-publish () {
- summary="${1}"
-
- silently "publish: add" "git add ."
- git commit --message="${summary}" 2>&1 >"/dev/null"
- silently "publish: push" "git push"
-}
-
-
-silently () {
- function="${1}"
- command="${2}"
- error=$(eval "${command}" 2>&1 >"/dev/null")
-
- if [ ${?} -ne 0 ]; then
- echo "${function}: ${error}" >&2
- exit 1
- fi
-}
-
-
-summary () {
- summary="${1}"
-
- if [ "${summary}" == "" ]; then
- echo $(date "+%Y-%m-%d %s")
- fi
-}
-
-
-updateInfoFile () {
- silently "updateInfoFile" "makepkg --printsrcinfo > .SRCINFO"
-}
-
-
-changeToThisProgramDir
-mainFunction ${@}