summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlberto Salvia Novella2019-11-15 09:42:16 +0100
committerAlberto Salvia Novella2019-11-15 09:42:16 +0100
commit6fab1f72a00c0ba55fc28377fb39c29c7b14e705 (patch)
tree84722c7be2a49b91e9b19b3ef0d6fbca3ae70b8d
parent41ba410dc7cf85ea1390203592ffb9b080fc7330 (diff)
downloadaur-6fab1f72a00c0ba55fc28377fb39c29c7b14e705.tar.gz
2019-11-15 1573807336
-rw-r--r--.SRCINFO7
-rwxr-xr-xPKGBUILD49
2 files changed, 27 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 12b3b9e4e754..33c7d355c512 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = qsyncthingtray-git
pkgdesc = Syncs files among devices, and shows the sync status on a tray icon. Version with the latest unreleased improvements.
- pkgver = 421
- pkgrel = 3
+ pkgver = r421
+ pkgrel = 2
url = https://github.com/sieren/QSyncthingTray
arch = i686
arch = x86_64
license = LGPL3
makedepends = cmake
- makedepends = commits-count-git
makedepends = git
depends = qt5-location
depends = qt5-webengine
@@ -15,8 +14,10 @@ pkgbase = qsyncthingtray-git
depends = syncthing
provides = qsyncthingtray
conflicts = qsyncthingtray
+ source = git+https://github.com/sieren/QSyncthingTray.git
source = qsyncthingtray.desktop
md5sums = SKIP
+ md5sums = SKIP
pkgname = qsyncthingtray-git
diff --git a/PKGBUILD b/PKGBUILD
index a94f873ce09c..00e32a4c8db4 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,32 @@
#! /bin/bash
-url="https://github.com/sieren/QSyncthingTray"
+Name="QSyncthingTray"
+LowercaseName=$(echo "${Name,,}")
+pkgname="${LowercaseName}-git"
+provides=("${LowercaseName}")
+conflicts=("${LowercaseName}")
+
+pkgdesc="Syncs files among devices, and shows the sync status on a tray icon. Version with the latest unreleased improvements."
+url="https://github.com/sieren/${Name}"
+license=("LGPL3")
+
+pkgver=r421
+pkgrel=2
+arch=("i686" "x86_64")
-pkgver() {
- commitsCount "${url}"
+makedepends=("cmake" "git")
+depends=("qt5-location" "qt5-webengine" "startup-settings-git" "syncthing")
+source=("git+${url}.git" "${LowercaseName}.desktop")
+md5sums=("SKIP" "SKIP")
+
+
+pkgver () {
+ cd "${Name}"
+ printf "r%s\n" "$(git rev-list --count HEAD)"
}
build() {
- cd "${srcdir}"
- git clone "${url}.git"
-
cd "${srcdir}/${Name}"
mkdir "build"
cd "build"
@@ -25,7 +41,7 @@ package() {
mkdir --parents "${pkgdir}/usr/share/pixmaps"
mkdir --parents "${pkgdir}/usr/share/applications"
- mv "${srcdir}/${Name}/build/${Name}" "${pkgdir}/usr/bin/${LowercaseName}"
+ cp "${srcdir}/${Name}/build/${Name}" "${pkgdir}/usr/bin/${LowercaseName}"
cp "${srcdir}/${Name}/resources/images/Icon1024.png" "${pkgdir}/usr/share/pixmaps/${LowercaseName}.png"
cp "${srcdir}/${LowercaseName}.desktop" "${pkgdir}/usr/share/applications/${LowercaseName}.desktop"
@@ -34,22 +50,3 @@ package() {
chmod +x "${pkgdir}/usr/bin/${LowercaseName}"
}
-
-Name="QSyncthingTray"
-LowercaseName=$(echo "${Name,,}")
-provides=("${LowercaseName}")
-conflicts=("${LowercaseName}")
-pkgname="${LowercaseName}-git"
-
-pkgdesc="Syncs files among devices, and shows the sync status on a tray icon. Version with the latest unreleased improvements."
-license=("LGPL3")
-
-pkgver=$(pkgver)
-pkgrel=3
-arch=("i686" "x86_64")
-
-makedepends=("cmake" "commits-count-git" "git")
-depends=("qt5-location" "qt5-webengine" "startup-settings-git" "syncthing")
-source=("${LowercaseName}.desktop")
-md5sums=("SKIP")
-