summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornull2015-08-26 15:51:30 -0400
committernull2015-08-26 15:51:30 -0400
commitda51136331707a0d3d0339fda0a953d3755a0970 (patch)
tree13387605e9b90850a27f9098df75689cd6bda4ec
downloadaur-da51136331707a0d3d0339fda0a953d3755a0970.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cedae590f798
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = qsynergy
+ pkgdesc = Qt gui for Synergy which lets you remotely control other computers.
+ pkgver = 0.9.1
+ pkgrel = 1
+ url = http://www.volker-lanz.de/en/software/qsynergy/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = qt
+ depends = synergy
+ source = http://sourceforge.net/projects/qsynergy/files/0.9.1/qsynergy-0.9.1.tar.gz
+ md5sums = 17d8989668016185b859332aacf9e7df
+
+pkgname = qsynergy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e170dba161e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Contributor: mutlu_inek <mutlu_inek@yahoo.de>
+pkgname=qsynergy
+pkgver=0.9.1
+pkgrel=1
+pkgdesc="Qt gui for Synergy which lets you remotely control other computers."
+url="http://www.volker-lanz.de/en/software/qsynergy/"
+license=(GPL)
+arch=('i686' 'x86_64')
+depends=('qt' 'synergy')
+makedepends=()
+conflicts=()
+provides=()
+source=(http://sourceforge.net/projects/$pkgname/files/$pkgver/$pkgname-$pkgver.tar.gz)
+md5sums=('17d8989668016185b859332aacf9e7df')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ qmake || return 1
+ make || return 1
+ install -D -m755 $startdir/src/$pkgname-$pkgver/dist/debian/qsynergy.desktop \
+ $startdir/pkg/usr/share/applications/qsynergy.desktop
+ install -D $startdir/src/$pkgname-$pkgver/dist/qsynergy.xpm $startdir/pkg/usr/share/pixmaps/qsynergy.xpm
+ install -D -m755 $startdir/src/$pkgname-$pkgver/qsynergy $startdir/pkg/usr/bin/qsynergy
+}