summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAli Molaei2022-06-06 22:40:40 +0430
committerAli Molaei2022-06-06 22:40:40 +0430
commitd57e746ce5ee4d05974f8c0e34f134b16b0e8bed (patch)
tree84fc3e16d542c0f8f230ffd9c69e76c968517bff
downloadaur-d57e746ce5ee4d05974f8c0e34f134b16b0e8bed.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD39
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..59bd41ab7d80
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = qt-aseman
+ pkgdesc = A set of C++ and QML tools and modules that helps you develop your projects easier and better.
+ pkgver = 3.1.5
+ pkgrel = 1
+ url = https://protonmail.com/bridge
+ arch = x86_64
+ license = LGPL3
+ makedepends = gcc
+ makedepends = make
+ makedepends = qt5-base
+ makedepends = git
+ options = !emptydirs
+ options = !strip
+ source = git+https://github.com/Aseman-Land/QtAseman.git#tag=v3.1.5
+ sha256sums = SKIP
+
+pkgname = qt-aseman
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..16f2a14a173f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+QtAseman*
+pkg/
+qt-aseman-*
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a871b5782b99
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Ali Molaei <ali dot molaei at protonmail dot com>
+
+pkgname=qt-aseman
+pkgver=3.1.5
+pkgrel=1
+pkgdesc="A set of C++ and QML tools and modules that helps you develop your projects easier and better."
+arch=('x86_64')
+url="https://protonmail.com/bridge"
+license=('LGPL3')
+makedepends=('gcc' 'make' 'qt5-base' 'git')
+options=('!emptydirs' '!strip')
+
+# Source to compile to a specific tag
+source=("git+https://github.com/Aseman-Land/QtAseman.git#tag=v${pkgver}")
+sha256sums=('SKIP')
+
+prepare() {
+ cd ${srcdir}/QtAseman/
+ mkdir -p build
+}
+
+build(){
+ cd ${srcdir}/QtAseman/build/
+ qmake -r ..
+ make -j2
+}
+
+package() {
+ install -dm755 "${pkgdir}"/usr/include
+ install -dm755 "${pkgdir}"/usr/lib/qt/qml/AsemanQml
+ install -dm755 "${pkgdir}"/usr/lib/qt/qml/QtQuick
+ install -dm755 "${pkgdir}"/usr/lib/qt/mkspecs/modules
+ cp -r ./QtAseman/build/lib/* "${pkgdir}"/usr/lib
+ cp -r ./QtAseman/build/mkspecs/modules/* "${pkgdir}"/usr/lib/qt/mkspecs/modules
+ cp -r ./QtAseman/build/include/* "${pkgdir}"/usr/include
+ cp -r ./QtAseman/build/qml/AsemanQml/* "${pkgdir}"/usr/lib/qt/qml/AsemanQml
+ cp -r ./QtAseman/build/qml/QtQuick/* "${pkgdir}"/usr/lib/qt/qml/QtQuick
+ install -D -m644 ./QtAseman/LICENSE -t "${pkgdir}"/usr/share/licenses/"${pkgname}"/
+}