summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikhail Rudenko2019-09-07 13:03:35 +0300
committerMikhail Rudenko2019-09-07 13:03:35 +0300
commite156e96c5626e6a2c00a98bd8ecd70c6c09619e4 (patch)
tree2c511c5c76da0ed3881e38211197bd441a8e70e3
downloadaur-qt-autoupdater.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c40cb24d8c67
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = qt-autoupdater
+ pkgdesc = A Qt library to automatically check for updates and install them
+ pkgver = 2.1.5_4
+ pkgrel = 1
+ url = https://skycoder42.github.io/QtAutoUpdater/
+ arch = x86_64
+ license = BSD
+ makedepends = qdep
+ makedepends = perl
+ depends = qt5-base
+ source = https://github.com/Skycoder42/QtAutoUpdater/archive/2.1.5-4.tar.gz
+ md5sums = 295433fc74597d539de845f3685a5258
+
+pkgname = qt-autoupdater
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..670503623992
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Mikhail Rudenko <mike.rudenko@gmail.com>
+pkgname=qt-autoupdater
+pkgver=2.1.5_4
+pkgrel=1
+pkgdesc="A Qt library to automatically check for updates and install them"
+arch=('x86_64')
+url="https://skycoder42.github.io/QtAutoUpdater/"
+license=('BSD')
+depends=('qt5-base')
+makedepends=('qdep' 'perl')
+source=(https://github.com/Skycoder42/QtAutoUpdater/archive/${pkgver//_/-}.tar.gz)
+md5sums=('295433fc74597d539de845f3685a5258')
+
+build() {
+ cd "$srcdir/QtAutoUpdater-${pkgver//_/-}"
+ qmake
+ perl -w /usr/bin/syncqt.pl -module QtAutoUpdaterCore -version 2.1.5 -outdir . -builddir . .
+ perl -w /usr/bin/syncqt.pl -module QtAutoUpdaterGui -version 2.1.5 -outdir . -builddir . .
+ make
+}
+
+package() {
+ cd "$srcdir/QtAutoUpdater-${pkgver//_/-}"
+ make INSTALL_ROOT="$pkgdir/" install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+}
+
+# vim:set ts=2 sw=2 et: