summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzan2020-06-09 02:27:29 -0400
committerzan2020-06-09 02:27:29 -0400
commit89157f439f59c453586afed5b0ef9cb47c88a662 (patch)
tree8a5e42e86069a38b82fba098147250b3292426a3
downloadaur-89157f439f59c453586afed5b0ef9cb47c88a662.tar.gz
Init
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..343da1698912
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = qt-avif-image-plugin-git
+ pkgdesc = Qt plug-in to allow Qt and KDE based applications to read/write AVIF images.
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/novomesk/qt-avif-image-plugin
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ makedepends = extra-cmake-modules
+ depends = qt5-base
+ depends = avif-git
+ source = git+https://github.com/novomesk/qt-avif-image-plugin.git
+ sha256sums = SKIP
+
+pkgname = qt-avif-image-plugin-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c070fa28fb48
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Zan <zan@cock.li>
+
+pkgname=qt-avif-image-plugin-git
+pkgver=1
+pkgrel=1
+pkgdesc='Qt plug-in to allow Qt and KDE based applications to read/write AVIF images.'
+arch=(x86_64)
+url='https://github.com/novomesk/qt-avif-image-plugin'
+license=('BSD')
+depends=(qt5-base avif-git)
+makedepends=(git extra-cmake-modules)
+source=("git+https://github.com/novomesk/qt-avif-image-plugin.git")
+sha256sums=('SKIP')
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake "../${pkgname%-git}"
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+ install -Dm644 $srcdir/LICENSE "/usr/share/licenses/$pkname/LICENSE"
+}